Bug 444726 - cpuspeed service does not start with kernel-2.6.24.5-85.fc8
cpuspeed service does not start with kernel-2.6.24.5-85.fc8
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 06:28 EDT by Radek Liboska
Modified: 2008-04-30 13:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 13:46:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmseg output (25.69 KB, text/plain)
2008-04-30 09:56 EDT, Radek Liboska
no flags Details
dsdt (18.49 KB, application/octet-stream)
2008-04-30 12:03 EDT, Radek Liboska
no flags Details

  None (edit)
Description Radek Liboska 2008-04-30 06:28:59 EDT
Description of problem:

CPU frequency scaling  (Intel(R) Core(TM)2 CPU) broken after upgrade from
kernel-2.6.24.4-64.fc8 to kernel-2.6.24.5-85.fc8

Version-Release number of selected component (if applicable):

2.6.24.5-85.fc8 #1 SMP Sat Apr 19 12:39:34 EDT 2008 i686 i686 i386 GNU/Linux


How reproducible:

always

Steps to Reproduce:
1.service cpuspeed status
cpuspeed is stopped
2.service cpuspeed start
3.service cpuspeed status
cpuspeed is stopped
  
Actual results:

cpuspeed service does not start, no cpufreq directory on
/sys/devices/system/cpu/cpu[0,1]/

Expected results:

running cpuspeed service

Additional info: manual loading of modules has no effect as well
Comment 1 Radek Liboska 2008-04-30 06:53:00 EDT
- after the update to kernel-2.6.24.5-85.fc8 even the kernel-2.6.24.4-64.fc8
lost its ability to run cpuspeed (with kernel-headers-2.6.24.5-85.fc8)
Comment 2 Dave Jones 2008-04-30 07:08:05 EDT
please boot with cpufreq.debug=7 and attach the output of dmesg.
Comment 3 Radek Liboska 2008-04-30 09:56:18 EDT
Created attachment 304228 [details]
dmseg output

dmseg created with cpufreq.debug=7 option
Comment 4 Radek Liboska 2008-04-30 10:21:42 EDT
dmseg says:
speedstep-lib: x86: 6, model: f
speedstep-ich: Intel(R) SpeedStep(TM) capable processor not found
speedstep-lib: x86: 6, model: f
speedstep-smi: No supported Intel CPU detected.

but
model           : 15
model name      : Intel(R) Core(TM)2 CPU          6320  @ 1.86GHz
stepping        : 6

actually IS SpeedStep(TM) capable!
Comment 5 Dave Jones 2008-04-30 10:58:53 EDT
That 'not found' message is expected.  There are 3 different variants of
speedstep, and that message comes from the driver for the pentium-III era
version of speedstep.

Your CPU should be using acpi-cpufreq, but for some reason it looks like that
isn't getting loaded.

Can you try modprobe acpi-cpufreq from the command line, and see what that does ?

Also, the output of /proc/cpuinfo might be handy.
Comment 6 Radek Liboska 2008-04-30 11:14:51 EDT
$ modprobe acpi-cpufreq
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.24.5-85.fc8/kernel/arch/x86/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device


CPU1 cpuinfo (CPU0 dupl.):
processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 CPU          6320  @ 1.86GHz
stepping        : 6
cpu MHz         : 1866.712
cache size      : 4096 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc
arch_perfmon pebs bts pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 3733.35
clflush size    : 64


Comment 7 Dave Jones 2008-04-30 11:24:13 EDT
ok, you have the est flag, so all should be good.  It looks like the BIOS for
some reason has broken P state tables.  Can you attach /proc/acpi/dsdt please ?

Also, you may want to make sure you're running the latest version of your BIOS
if there are updates available.
Comment 8 Radek Liboska 2008-04-30 12:02:42 EDT
I have encountered some problems with BIOS already (freezing, BIOS CRC checksum
error). I'll try re-flashing it.
Comment 9 Radek Liboska 2008-04-30 12:03:39 EDT
Created attachment 304249 [details]
dsdt
Comment 10 Radek Liboska 2008-04-30 12:58:37 EDT
Dave, thanks for your help and sorry for wasting your time! The BIOS updating
solves the issue. Now the cpuspeed is working again. (However the
"speedstep-ich: Intel(R) SpeedStep(TM) capable processor not found" message is
still present)
You can close this bug.
Have a nice day and thanks again

Radek

Note You need to log in before you can comment on or make changes to this bug.