Bug 444748 - NetworkManager-vpnc will not connect while vpnc will connect.
NetworkManager-vpnc will not connect while vpnc will connect.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
8
i386 Linux
high Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 10:02 EDT by Darryl L. Pierce
Modified: 2015-06-21 20:06 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 10:10:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Part of /var/log/messages related to the issue (I believe) (4.59 KB, text/plain)
2008-08-17 17:30 EDT, Matěj Cepl
no flags Details
Screenshot of the error message (21.64 KB, image/png)
2008-08-17 17:31 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Darryl L. Pierce 2008-04-30 10:02:22 EDT
Description of problem:

Unable to establish a VPN connection when using VPN configured within
NetworkManager. However, from the commandline using VPNC the connection works
perfectly.


Version-Release number of selected component (if applicable):

NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8


How reproducible:

Steps to Reproduce:
1. Configure a VPN connection.
2. Attempt to establish the connection.
3. The connection fails every time.
4. Configure the same connection via the commandline with VPNC
5. Attempt to establish the connection.
6. Connection succeeds.

  
Actual results:

Connections never succeed with NetworkManager-vpnc.

Expected results:

Connections succeed.

Additional info:

A friend of mine has the same setup and the same problem.
Comment 1 Denis Leroy 2008-04-30 10:07:10 EDT
Could you provide the exact vpnc command that is working ?
Comment 2 Darryl L. Pierce 2008-04-30 10:32:34 EDT
/usr/sbin/vpnc to connect. My scrubbed VPN configuration is:

[root@mcpierce-laptop ~]# cat /etc/vpnc/default.conf 
IPSec gateway ###.###.###.###
IPSec ID ******
IPSec secret ******
# your username goes here:
Xauth dpierce
Comment 3 Dan O'Brien 2008-06-02 11:01:34 EDT
I also seem to having the same issue. Everything was fine up until a few days
ago. I was able to connect without issue, then it just stopped working. Now when
I try,  I get the popup that prompts me for my password / group password, I
enter it then it just stops trying to connect. I see the following in
/var/log/messages

Jun  2 10:46:07 NY-0999-LX-01 NetworkManager: <info>  VPN connection 'MYVPN'
(Connect) reply received.
Jun  2 10:46:07 NY-0999-LX-01 kernel: tun0: Disabled Privacy Extensions
Jun  2 10:46:08 NY-0999-LX-01 NetworkManager: <WARN> 
connection_state_changed(): Could not process the request because no VPN
connection was active.


Comment 5 Martin-Gomez Pablo 2008-07-14 04:27:00 EDT
I can confirm the issue. To give a little bit more information :

[root@localhost ~]# nm-vpnc-service
** Message: <info>  vpnc started with pid 5669

/usr/sbin/vpnc: warning: unknown configuration directive in stdin at line 7
/usr/sbin/vpnc: missing Xauth password

** (process:5661): WARNING **: <WARN>  vpnc_watch_cb(): vpnc exited with error
code 1

[root@localhost ~]# nm-vpnc-service-vpnc-helper 

** (process:5660): WARNING **: <WARN>  helper_failed():
nm-nvpnc-service-vpnc-helper did not receive a valid VPN Gateway from vpnc


** (process:5660): WARNING **: <WARN>  helper_failed(): Could not send failure
information: The name org.freedesktop.NetworkManager.vpnc was not provided by
any .service files

[root@localhost ~]# cat /etc/vpnc/default.conf 
## generated by pcf2vpnc
IPSec ID ***********
IPSec gateway vpn.*********
IPSec secret *******

Xauth username JCM
Xauth password ******
IKE Authmode psk
Comment 6 Matěj Cepl 2008-08-17 17:30:33 EDT
Created attachment 314454 [details]
Part of /var/log/messages related to the issue (I believe)

I think I have similar issue here -- vpnc works without any problems with this (sanitized) /etc/vpnc/default.conf

[root@viklef ~]# grep -v ^# /etc/vpnc/default.conf
IPSec gateway jadajada.redhat.com
IPSec ID jadajada
IPSec secret jadajada
Xauth username mcepl
Interface name tun0
Script INTERNAL_IP4_DNS= /etc/vpnc/vpnc-script
[root@viklef ~]# 

but NetworkManager-vpnc (which used to work pretty well with the exactly very same configuration like a month ago) fails with the message "VPN Connection Failed: The VPN connection 'RH VPN' failed because the VPN service stopped unexpectedly."
Comment 7 Matěj Cepl 2008-08-17 17:31:29 EDT
Created attachment 314455 [details]
Screenshot of the error message
Comment 8 Dan Williams 2008-11-17 09:19:35 EST
Is this still an issue with latest F9 updates (ie, svn4022 or later)?
Comment 9 Darryl L. Pierce 2008-11-17 09:28:16 EST
No, I have not had an issue with it in some time now.
Comment 10 Dan Williams 2008-11-17 10:10:06 EST
ok, thanks!

Note You need to log in before you can comment on or make changes to this bug.