This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 444816 - Lots of "auto" entries in wireless submenu
Lots of "auto" entries in wireless submenu
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 15:07 EDT by Daryll
Modified: 2008-04-30 16:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 16:40:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daryll 2008-04-30 15:07:50 EDT
This latest version of NetworkManager (NetworkManager-0.7.0-0.6.7.svn3370.fc8)
that went out today changed the appearance of the popup menu. Under wireless
networks I see a list of the networks in my area. Next to my specific network
(daryllnet) there is a submenu. That submenu has a huge list of entries that all
say "auto daryllnet".

I have always had somewhat odd behavior with NetworkManager. Sometimes I have to
kill it and restart it to get it to see and connect to my networks. I had to do
that today with the newest NetworkManager release. Sometimes I found that if the
network was displayed selecting it multiple times would get it to connect. Some
times I found that killing and restarting it didn't fix the problem but saying
"connect to other wireless network" and filling in the values for my network
would get it to connect when daryllnet wasn't showing up in the menu. My
suspicion is that every time I told it to connect to another network it made
another one of those submenu entries.

I'd like to clean up the entries in the submenu, but I can't find where they're
stored. I'd like to have the connections be more reliable. That may already be
true with the new kernel and new NetworkManager, but I can't tell until I run it
longer.
Comment 1 Dan Williams 2008-04-30 16:19:38 EDT
These entries were due to a bug in the NM applet before multiple connection
support landed.  You're completely right, the applet was not correctly finding
and matching existing saved networks when you picked "Connect to other...".

You can remove the ones you don't need by right-clicking on the NM applet and
choosing "Edit connections...", or you can run /usr/bin/nm-connection-editor and
delete the ones you do not need.  Let me know if that works for you!
Comment 2 Daryll 2008-04-30 16:37:36 EDT
I went through all of them and deleted them until I was down to one. That fixed
the problem.

I'm not sure if this is "Fixed" or "NotABug" so I'll let you close it.
Comment 3 Dan Williams 2008-04-30 16:40:08 EDT
All the bugs that caused the behavior have been fixes, so Fixed it is.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.