Bug 444821 - unaligned access messages during kickstart install
Summary: unaligned access messages during kickstart install
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: libnl   
(Show other bugs)
Version: 9
Hardware: ia64
OS: Linux
low
low
Target Milestone: ---
Assignee: Doug Chapman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-30 20:04 UTC by Bryan Stillwell
Modified: 2009-01-27 15:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 15:51:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart script used to install on /dev/sda (515 bytes, text/plain)
2008-04-30 20:04 UTC, Bryan Stillwell
no flags Details
First 5 unaligned access messages (6.82 KB, image/png)
2008-04-30 20:05 UTC, Bryan Stillwell
no flags Details
Second 5 unaligned access messages (4.11 KB, image/png)
2008-04-30 20:06 UTC, Bryan Stillwell
no flags Details

Description Bryan Stillwell 2008-04-30 20:04:43 UTC
Description of problem:
When installing rawhide on an rx2660 I saw the attached 'unaligned access' messages.

Version-Release number of selected component (if applicable):
# uname -a
Linux med1-ofs.lionc.test 2.6.25-1.fc9.ia64 #1 SMP Sun Apr 20 07:00:15 EDT 2008
ia64 ia64 ia64 GNU/Linux

How reproducible: 100%


Steps to Reproduce:
1. Setup an rx2660 using the lsi1068 for the coreIO
2. Use the attached kickstart file to install on /dev/sda
3. Witness the unaligned access messages seen in the attached screenshots
  
Actual results: multiple 'unaligned access' messages


Expected results: Clean install without warnings


Additional info:

Comment 1 Bryan Stillwell 2008-04-30 20:04:43 UTC
Created attachment 304270 [details]
kickstart script used to install on /dev/sda

Comment 2 Bryan Stillwell 2008-04-30 20:05:37 UTC
Created attachment 304271 [details]
First 5 unaligned access messages

Comment 3 Bryan Stillwell 2008-04-30 20:06:24 UTC
Created attachment 304272 [details]
Second 5 unaligned access messages

Comment 4 Doug Chapman 2008-04-30 20:12:10 UTC
My assumption this is the same libnl issue that we recently fixed in RHEL 5.2. 
I will investigate but for now moving to libnl.


Comment 5 Bryan Stillwell 2008-04-30 20:30:35 UTC
Package revisions:

anaconda-11.4.0.75-1
libnl-1.1-3.fc9

Comment 6 Doug Chapman 2008-04-30 21:32:09 UTC
Adding dcbw and tgraf to the CC list.

This is identical to what we recently fixed in RHEL5.2 (BZ 434826).  Do we want
to fix this in the same way?  I know there were other ideas on how to better fix
this however we didn't want to break binary compatibility on RHEL5.X.  Perhaps
we want to implement that fix in Fedora.


Comment 7 Thomas Graf 2008-04-30 22:18:02 UTC
The way it was fixed in RHEL5.2 is also the way I fixed this upstream. There is
really is no other way unless the kernel enters an unstable cycle again allowing
for the netlink protocols to break.

Comment 8 Bug Zapper 2008-05-14 10:26:42 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 9 Doug Chapman 2009-01-27 15:51:25 UTC
Closing since we are not currently building Fedora on ia64.  Will re-open if this is still seen once builds begin again.


Note You need to log in before you can comment on or make changes to this bug.