Bug 444856 - [REGRESSION] Cannot connect after last wpa_supplicant upgrade
[REGRESSION] Cannot connect after last wpa_supplicant upgrade
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 05:42 EDT by Răzvan Sandu
Modified: 2008-07-01 07:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-01 07:21:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-05-01 05:42:55 EDT
Description of problem:

Hello,

Despite the fact that wpa_supplicant didn't started at boot on my Dell Inspiron
1520, I used the following manual procedure to succesfully connect to wi-fi
after boot:

- service wpa_supplicant restart
- wlassistant

After the latest wpa_supplicant upgrade (via official updates), this procedure
ceased to work and I cannot use wireless (now wlassistant seems to be unable to
connect to the *same* wi-fi network, using wpa2 with preshared key and DHCP).

Upgrading from F8 to the lastest rawhide didn't help me.

Version-Release number of selected component (if applicable):
wpa_supplicant-0.6.3-5.fc9.x86_64
wlassistant-0.5.7-7.fc9.x86_64

How reproducible:
Always.

  
Actual results:
Have no way to use the wireless connection on a Dell Inspiron 1520.
(hardware profile here
http://www.smolts.org/client/show/pub_9d69eb22-c7a0-44ea-9e54-a49aa186b94c)


Expected results:
There should be a (canonical) way to connect to a wi-fi network.

Additional info:
As discussed in bug #375721 and bug #244029, I've tried the tips suggested there
in F8+updates. Unfortunately, the procedure detailed at
http://www-users.york.ac.uk/~mdc1/fedora_wireless.html didn't work in my case.
Comment 1 Dan Williams 2008-05-01 06:20:13 EDT
Could you enable supplicant logging?  Add "-dddt" to the OTHER_FLAGS line in
/etc/sysconfig/wpa_supplicant, restart, and then attach
/var/log/wpa_supplicant.log to this bug report after having attempted a
connection to your AP.  Thanks!
Comment 2 Dan Williams 2008-05-01 06:20:48 EDT
Add "-dddt" to OTHER_ARGS I mean, not OTHER_FLAGS.
Comment 3 Răzvan Sandu 2008-05-01 07:58:58 EDT
Hello,

Here's the requested info: /var/log/wpa_supplicant.log only lists:

[root@mazarin ~]# cat /var/log/wpa_supplicant.log
Could not request DBus service name: already registered.
Could not request DBus service name: already registered.
Could not request DBus service name: already registered.
1209642029.889509: Providing DBus service 'fi.epitest.hostap.WPASupplicant'.
1209642029.898318: Daemonize..

However, here's what I get in a background terminal, by manually invoking
wlassistant:

[root@mazarin ~]# wlassistant
Loaded application options.
All interfaces: eth0, sit0, virbr0, wlan0, wmaster0
Wireless interface(s): wlan0
Permissions checked.
DHCP Client: dhclient
All executables found.
scan: /sbin/iwlist wlan0 scan
Networks found: 1
No DHCP client running.
No pre-connection command specified.
iwconfig_set: /sbin/iwconfig wlan0 mode managed channel 9 key off essid zando
iwconfig_ap: /sbin/iwconfig wlan0 ap 00:19:5B:0E:A6:27
==>stderr: Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or
directory
Using wpa_supplicant driver: wext
WPA client started. Waiting for status...
==>stderr: Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or
directory
CONNECTION FAILED.
disconnect: /sbin/iwconfig wlan0 mode managed key off ap off essid off


...and remains at the above line until I manually close wlassistant. "zando" is
the SSID of my wireless network.


Regards,
Răzvan
Comment 4 Răzvan Sandu 2008-05-07 16:34:57 EDT
Hello,

Now the wpa_supplicant not starting at boot seems to be fixed (it starts OK
now), but I still can't connect to the wireless network (at least with wlassistant).

Could you please indicate a *canonical* (= Red Hat manual-like ;-) ) way to
start, stop the wireless connection, change the IP address, verify the
connection & signal strength, etc.  ?

Should I use the "classic" system-config-network or NetworkManager ? 

wlassistant-0.5.7-7.fc9.x86_64
wpa_supplicant-0.6.3-5.fc9.x86_64
NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386
NetworkManager-0.7.0-0.9.3.svn3623.fc9.x86_64

Regards,
Răzvan



Comment 5 Dan Williams 2008-05-08 14:25:39 EDT
NetworkManager is the canonical way to do this in F9.  Can you try with NM?
Comment 6 Răzvan Sandu 2008-05-08 14:47:09 EDT
Thanks for your info !


Now that wpa_supplicant starts automatically at boot, I will enable NM to start
at boot also (if not already).

Could you please detail the *next steps* I should follow to configure and test
the wireless interface using NM ? For example:

- assign a manual IP (*or* an automatic one by DHCP - but I don't have DHCP in
all networks)
- insert my WPA2 preshared key (password) and complete authentication;
- monitor the wireless network (signal strength, other parameters, etc.), best
via a graphical GNOME applet.


Thanks a lot,
Răzvan
Comment 7 Răzvan Sandu 2008-05-13 03:23:48 EDT
Hello,

After the last updates (I'm running Fedora 9 preview release with latest updates
as of May 13, 2008) *and* after enabling NetworkManager, wireless connection
"magically" started to work.

However, when enabling the wireless interface (that uses WPA2), two dialogs show up:

- one asking for the WPA2 preshared key;
- one stating:

"Enter password for default keyring to unlock.

The application NetworkManager Applet /usr/bin/nm-applet wants access to default
keyring, but it is locked".

Since I didn't setup any key on my keyring, I have no password to insert.
Clicking Deny leads however to succesful connection, but the dialog is strange
for non-technical users.

Regards,
Răzvan


Comment 8 Bug Zapper 2008-05-14 06:27:46 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.