Bug 444861 - laptop can't wake up after closing the lid
laptop can't wake up after closing the lid
Status: CLOSED DUPLICATE of bug 414971
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 06:24 EDT by Mikel Ward
Modified: 2013-03-05 22:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-14 07:08:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikel Ward 2008-05-01 06:24:18 EDT
When I close my laptop's lid, it seems to go into sleep mode (the power LED stay
on solid and the screen goes blank).  If I press anything (keyboard, mouse,
etc.) it stays black.

I'm using F9 with latest updates, XFce desktop environment, with
gnome-power-manager running, kernel 2.6.25-8.fc9.i686, on a Dell D630 laptop.
Comment 1 Mikel Ward 2008-05-01 06:27:18 EDT
Actually, I think it's just blanking the screen.  If it was in sleep mode, the
light would flash, wouldn't it?

GNOME battery applet preferences show it's configured to blank the screen when
the lid is closed.
Comment 2 Mikel Ward 2008-05-01 06:30:01 EDT
Sorry.  Blank screen if on AC power, but I'm currently on battery power, which
is configured to suspend.   Will confirm what the lights are doing just to be sure.
Comment 3 Mikel Ward 2008-05-01 06:37:15 EDT
Bluetooth and Wi-Fi lights go off and the power light blinks after closing the lid.

Power light comes back on and I think the bluetooth and wi-fi lights come back
on when opening the lid.  The screen stays completely black.  Ctrl+Alt+Backspace
does nothing.  Ctrl+Alt+F1 thru F7 do nothing.  Ctrl+Alt+Delete eventually reboots.
Comment 4 Matthias Clasen 2008-05-01 09:53:42 EDT
Sounds like a backlight problem ?
Comment 5 Bug Zapper 2008-05-14 06:27:59 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Mikel Ward 2008-06-04 06:35:56 EDT
Still seeing something along these lines.

Currently, I see a single blinking underscore (a _ style cursor) in the top left
corner for a while, then the screen lights up more but stays black.  Everything
else is as described.
Comment 7 Mikel Ward 2008-06-04 06:38:06 EDT
It's more like this, where they mention your screen could be blank after resuming.
http://www.linux.com/articles/54610
Comment 8 Mikel Ward 2008-06-14 07:03:59 EDT
Sounds like it's a known bug in the nv display driver.
http://fedoraproject.org/wiki/Bugs/F8Common#nv-suspend

Assigning to that project.
Comment 9 Mikel Ward 2008-06-14 07:08:43 EDT
It'll be a dupe of bug 429957 or bug 414971.

Picking 414971, since that one has more activity and is the earlier bug.

*** This bug has been marked as a duplicate of 414971 ***
Comment 10 Mikel Ward 2008-06-15 01:42:32 EDT
Yep, finally managed to get the nvidia driver installed (rather than nv), and it
suspends properly.

Note You need to log in before you can comment on or make changes to this bug.