Bug 444873 - Duplex shouldn't affect number of copies
Duplex shouldn't affect number of copies
Status: CLOSED DUPLICATE of bug 303401
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 09:07 EDT by Rodd Clarkson
Modified: 2008-05-02 09:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 09:33:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2008-05-01 09:07:55 EDT
Description of problem:

I have a printer that can duplex.

If I print a single page 10 times with the duplexing on, I currently get 5
printed pages with the same page printed 10 time one on each side of the page.

What I should get is 10 printed pages with a copy of the page on one side.

Duplex shouldn't affect how many copies I get.  While I haven't tried the
following, I imagine that if I printed a 3 page document multiple times with
duplex on, I would get a mess of paper with the start of the document on the
back of the last page in every second case.


Version-Release number of selected component (if applicable):

f9-preview

[rodd@localhost ~]$ rpm -qa | grep cups
cups-libs-1.3.7-1.fc9.i386
libgnomecups-0.2.3-3.fc9.i386
hal-cups-utils-0.6.16-3.fc9.i386
bluez-utils-cups-3.30-2.fc9.i386
cupsddk-drivers-1.2.3-4.fc9.i386
cups-1.3.7-1.fc9.i386
[rodd@localhost ~]$ 


How reproducible:

Very

Steps to Reproduce:
1. Print a 1 page document on a printer that can duplex.
2. Change the number of copies to more than 1

  
Actual results:

The same page is printed both sides


Expected results:

The same page should be printed on a new page for each copy.
Comment 1 Tim Waugh 2008-05-01 09:25:44 EDT
How exactly are you printing?  The application you are printing from makes a
difference.  Is it evince, openoffice, something else..?
Comment 2 Rodd Clarkson 2008-05-02 05:28:49 EDT
I was printing from evince in this case.
Comment 3 Rodd Clarkson 2008-05-02 05:32:32 EDT
Okay, I just tested OOo and it works as expected, however I noticed that the
printer still sucked the page back in, it just didn't print on the back side.

So, has this something to do with the application not sending two pages to the
printer (or more correctly, an even number of pages)?
Comment 4 Tim Waugh 2008-05-02 09:33:33 EDT
The printer will suck the page back in and flip it in order to have the pages in
the output tray the right way up. (Think about a document with n pages, n > 1
and n odd.)

Evince is a known offender with this.  Marking as a duplicate.

(Hey, someone other than me filing duplex-printing bugs!  Yay!)

*** This bug has been marked as a duplicate of 303401 ***

Note You need to log in before you can comment on or make changes to this bug.