Bug 444887 - Importing bookmarks fails to load subfolders
Importing bookmarks fails to load subfolders
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 11:40 EDT by Christopher Tubbs
Modified: 2008-05-06 13:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 13:36:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Firefox 2 bookmarks (195.03 KB, text/html)
2008-05-01 22:45 EDT, Christopher Tubbs
no flags Details
Screenshot (69.24 KB, image/png)
2008-05-03 07:31 EDT, Matěj Cepl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 427310 None None None Never

  None (edit)
Description Christopher Tubbs 2008-05-01 11:40:44 EDT
Description of problem:
Bookmarks that were created with firefox 2 (bookmarks.html) do not fully import
into firefox 3. In particular, when importing, bookmarks in subfolders in
bookmark toolbar do not load and subfolders that previously contained bookmarks
in firefox 2 are empty after import in firefox 3.

Version-Release number of selected component (if applicable):
firefox-3.0-0.59.beta5.fc9.i386

How reproducible:
Tried twice, with same result.

Steps to Reproduce:
1. In firefox 2, populate bookmark toolbar with folders of bookmarks, including
some sub-folders with more bookmarks.
2. Install F9 preview with firefox 3
3. Go to Bookmarks->Organize Bookmarks
4. Click on "Import and Backup"->Import->Import from file
5. Select firefox2 bookmarks.html that was created in step one.
  
Actual results:
Bookmark sub-folders are empty.

Expected results:
Bookmark sub-folders should contain the bookmarks created in firefox 2.

Additional info:
Using F9 Preview i386

Selected high severity, because it significantly affects user's ability to
transition to Fedora release: basic expectations of transition, like
transferring browser settings, are not met.
Comment 1 Christopher Aillon 2008-05-01 11:51:40 EDT
Can you post your generated bookmarks.html that exhibits this?
Comment 2 Christopher Tubbs 2008-05-01 22:02:22 EDT
Sorry, I cannot. My only bookmarks.html file generated from firefox 2 contains a
lot of banking/private links. Nor do I have access to another installation of
firefox 2, so I can recreate one (and I'm not reverting from F9 just to test
this). Hopefully somebody else can provide a generated one.

Would it have mattered that I used the bookmarks.html file in my firefox profile
directly, without explicitly exporting them to a new file?
Comment 3 Christopher Aillon 2008-05-01 22:23:12 EDT
It shouldn't, but I can't reproduce given your steps which you apparently didn't
even follow... nor can i reproduce on an F8->F9 upgrade, which effectively does
what you just did (go from Fx2 to Fx3 without actually exporting/importing)
Comment 4 Christopher Tubbs 2008-05-01 22:45:32 EDT
Created attachment 304357 [details]
Firefox 2 bookmarks

I followed my steps, I just didn't specify which bookmarks.html file I used (I
used the one in the firefox profile folder, not exported from bookmarks
interface). I went from F7->F9, and noticed the problem. I looked again at the
bookmarks file I used, and determined it'd be okay to post it here. (it's not
incriminating to know where I bank or that I do my parent's finances, or that I
live in Ypsilanti, and am still a student, I suppose... :)
Comment 5 Matěj Cepl 2008-05-03 07:18:46 EDT
Yes, can fully reproduce with firefox-3.0-0.60.beta5.fc9.i386 Removed
~/.mozilla, restarted FF, imported attached bookmark.html and really there was
no bookmark imported.
Comment 6 Matěj Cepl 2008-05-03 07:31:19 EDT
Created attachment 304446 [details]
Screenshot

(In reply to comment #5)
> Yes, can fully reproduce with firefox-3.0-0.60.beta5.fc9.i386 Removed
> ~/.mozilla, restarted FF, imported attached bookmark.html and really there
was
> no bookmark imported.

Sorry, this is mistake -- I just couldn't find the bookmarks before -- they are
so deeply nested.
Comment 7 Matěj Cepl 2008-05-03 07:31:52 EDT
Reporter, are you sure, that the bookmarks are not somewhere deeply hidden?
Comment 8 Christopher Tubbs 2008-05-03 22:32:34 EDT
I'm sure they aren't where they are supposed to be. I don't know any other place
they could be. For example, the "Bookmarks Toolbar Folder"->Other->Linux folder
is empty after import, but it is clearly not empty if you view the
bookmarks.html page directly. It seems like it stops importing at a certain
nested depth.
Comment 10 Matěj Cepl 2008-05-06 13:36:28 EDT
We found that this bug has been already registered in the upstream database
(https://bugzilla.mozilla.org/show_bug.cgi?id=427310) and believe that it is
more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.