Bug 444888 - RFE: switch to PackageKit
RFE: switch to PackageKit
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 11:41 EDT by Rahul Sundaram
Modified: 2014-06-30 19:21 EDT (History)
2 users (show)

See Also:
Fixed In Version: system-config-language-2.2.0-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-30 19:21:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2008-05-01 11:41:57 EDT
Description of problem:

A local copy of Pirut code is being used in current Rawhide. PackageKit (git
version) has the ability to use a dbus session to install packages easily. We
should switch to that. Note that the target would be Fedora 10. 

Sample code:

#include <dbus/dbus-glib.h>

DBusGConnection *connection;
DBusGProxy *proxy;
GError *error = NULL;
gboolean ret;

connection = dbus_g_bus_get (DBUS_BUS_SESSION, NULL);
proxy = dbus_g_proxy_new_for_name (connection,
                             "org.freedesktop.PackageKit",
                             "/org/freedesktop/PackageKit",
                             "org.freedesktop.PackageKit");
/* execute sync method */
ret = dbus_g_proxy_call (proxy, "InstallPackageName", &error,
                         G_TYPE_STRING, "lohit-fonts-malayalam",
                         G_TYPE_INVALID, G_TYPE_INVALID);
if (!ret) {
        g_warning ("failed: %s", error->message);
        g_error_free (error);
}

Instead of InstallPackageName, it is also possible to use InstallProvideFile and
InstallLocalFile. I will submit a patch if I can tweak this package to do the
right thing.
Comment 1 Bug Zapper 2008-05-14 06:28:50 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Paul W. Frields 2008-08-10 16:47:15 EDT
Triage here.  Any luck on the patch, or change in status?
Comment 3 Rahul Sundaram 2008-08-10 17:02:53 EDT
In the earlier discussion I had with the maintainer, we mistakenly had the impression about the usage of Pirut and it would have been a serious problem then due to the switch to PackageKit. This tool instead actually uses yum API directly. We could still use my patch or a variant to switch to the PackageKit API but that is currently low priority as I understand it
Comment 4 Tony Fu 2008-09-09 23:15:38 EDT
requested by Jens Petersen (#27995)
Comment 5 Bug Zapper 2008-11-25 21:14:43 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Fedora Admin XMLRPC Client 2011-03-04 04:06:52 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Admin XMLRPC Client 2011-06-16 04:49:13 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora Admin XMLRPC Client 2013-01-28 00:50:03 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Parag Nemade 2014-06-14 07:54:57 EDT
Fixed in system-config-language-2.1.0-1.fc21
Comment 11 Fedora Update System 2014-06-19 09:36:10 EDT
system-config-language-2.2.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/system-config-language-2.2.0-2.fc20
Comment 12 Fedora Update System 2014-06-19 18:57:05 EDT
Package system-config-language-2.2.0-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-language-2.2.0-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7516/system-config-language-2.2.0-2.fc20
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2014-06-30 19:21:15 EDT
system-config-language-2.2.0-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.