Bug 444890 - Garbled fonts
Garbled fonts
Status: CLOSED DUPLICATE of bug 466369
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
powerpc Linux
high Severity high
: ---
: ---
Assigned To: Dave Airlie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 11:48 EDT by Peter Lemenkov
Modified: 2009-02-21 03:44 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 14:40:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log from the URL in comment 1 (42.44 KB, text/plain)
2008-05-02 12:07 EDT, Matěj Cepl
no flags Details
/etc/X11/xorg.conf from comment 1 (2.96 KB, text/plain)
2008-05-02 12:07 EDT, Matěj Cepl
no flags Details
Xorg log, comment #9 (68.52 KB, application/octet-stream)
2008-12-18 10:35 EST, Mikko Huhtala
no flags Details
Text rendering with xorg-x11-drv-ati-6.9.0-63.fc10.ppc. (436.72 KB, image/png)
2008-12-27 06:30 EST, Peter Lemenkov
no flags Details
Corrupted font rendering (144.00 KB, image/png)
2008-12-31 17:26 EST, Robert Hancock
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 19363 None None None Never

  None (edit)
Description Peter Lemenkov 2008-05-01 11:48:32 EDT
Description of problem:
After I started firefox, I see garbled fonts (see screenshots) after some little amount of time. This issue 
is also observed by me in other GTK2 application I'm using - GQview.

Looks like Qt application I'm using (Psi) doesn't produces this issue by itself but when Firefox corrupts 
fonts, Psi is also shows us damaged ones. I can suppose that it's due to some GTK2-X11 font relations 
but I'm not sure.

Version-Release number of selected component (if applicable):
Fedora 9-Preview
xorg-x11-server-Xorg-1.4.99.901-26.20080415.fc9.ppc
gtk2-2.12.9-5.fc9.ppc
firefox-3.0-0.59.beta5.fc9.ppc

How reproducible:
Always

Steps to Reproduce:
1. Start Firefox
2. Wait until it stops consuming 90+ percents of CPU and will be at least responsible
3. Surf the web a little
4. See corrupted fonts
  
Actual results:
http://peter.fedorapeople.org/bad_fonts.png
http://peter.fedorapeople.org/bad_fonts2.png
http://peter.fedorapeople.org/bad_fonts3.png

Also there is a screenshot with Psi:

http://peter.fedorapeople.org/bad_fonts_psi.png
Comment 1 Peter Lemenkov 2008-05-01 12:03:49 EDT
Here is Xorg-log and Xorg config:

http://peter.fedorapeople.org/Xorg.0.log
http://peter.fedorapeople.org/xorg.conf
Comment 2 Peter Lemenkov 2008-05-01 12:05:29 EDT
Smolt profile for this system

http://www.smolts.org/client/show?uuid=pub_1b7e5d26-dbec-461f-af16-716b52ad2281
Comment 3 Peter Lemenkov 2008-05-02 05:35:36 EDT
Commenting out 	Option "AccelMethod" "exa" solved the issue. Since EXA is
obsolete, it's not a solution but rather a workaround.

See also

http://bugs.freedesktop.org/show_bug.cgi?id=15611
Comment 4 Peter Lemenkov 2008-05-02 08:45:07 EDT
> Since EXA is obsolete

Oops. I mean XAA.
Comment 5 Matěj Cepl 2008-05-02 12:07:21 EDT
Created attachment 304396 [details]
/var/log/Xorg.0.log from the URL in comment 1
Comment 6 Matěj Cepl 2008-05-02 12:07:56 EDT
Created attachment 304397 [details]
/etc/X11/xorg.conf from comment 1

We prefer everything in our database (so it won't get lost)
Comment 7 Bug Zapper 2008-05-14 06:29:02 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Peter Lemenkov 2008-12-09 02:55:09 EST
This issue was gone, then I switched to 16-bit mode.

See also BZ #473440

https://bugzilla.redhat.com/show_bug.cgi?id=473440

Probably these two tickets are symptoms of one common issue?
Comment 9 Mikko Huhtala 2008-12-18 10:34:05 EST
I'm also seeing garbled fonts on up-to-date F10 on a ThinkPad R50 with RV250 [Mobility FireGL 9000] (rev 02). All fonts of all X applications/toolkits are garbled, including gdm. I.e. the fonts are garbled before I even log in, so this seems unrelated to the length of the session or load.

Fonts are ok when I use the F10 preview live cd, so the problem seems to have appeared after an update. I installed today from preview live cd ('install to hard drive'), then updated to current F10 (release, no rawhide) with yum. I now have

xorg-x11-server-Xorg-1.5.3-6.fc10.i386
xorg-x11-drv-ati-6.9.0-62.fc10.i386
kernel-2.6.27.7-134.fc10.i686

Will attach Xorg.0.log.
Comment 10 Mikko Huhtala 2008-12-18 10:35:27 EST
Created attachment 327333 [details]
Xorg log, comment #9

Xorg log, comment #9
Comment 11 Mikko Huhtala 2008-12-19 07:42:24 EST
Tested with the ATI driver version from F10 release day, xorg-x11-drv-ati-6.9.0-54, and it works. All other Xorg packages are the same. So, the font rendering apparently breaks between 54 and 62.
Comment 12 Peter Lemenkov 2008-12-27 06:27:32 EST
Are you working on x86 or powerpc platform?
I still have no luck with latest xorg-x11-drv-ato for F10 (see attached file)
Comment 13 Peter Lemenkov 2008-12-27 06:30:24 EST
Created attachment 327881 [details]
Text rendering with xorg-x11-drv-ati-6.9.0-63.fc10.ppc.

Text rendering with xorg-x11-drv-ati-6.9.0-63.fc10.ppc.
Note the yellow "echo" at the end of some words.
Comment 14 Peter Lemenkov 2008-12-27 06:36:00 EST
Good news is that I clearly see some progress - my only Qt application (Psi) seems no longer affected by this bug.

Also, I can read (and write) texts nowadays - this yellow tail is the only issue remaining. It looks like something "eats" tails of some words and replaces eaten parts with their yellow shadows :).

I'll try latest git version.
Comment 15 Mikko Huhtala 2008-12-28 05:44:30 EST
I've only seen this problem on a ThinkPad R50 (Pentium M) and an even older ThinkPad A30 (Pentium III Mobile, Radeon Mobility M6 LY), which are both x86. I don't have access to the machines right now (I'm away for Christmas), so I cannot test the git version or such.
Comment 16 Robert Hancock 2008-12-31 17:25:48 EST
Seeing some font corruption on my Compaq Presario X1000 system with Radeon Mobility 9000 graphics. Fonts have some "static" above or below lines of text in some cases. Will attach screenshot.

This is with xorg-x11-drv-ati-6.9.0-63.fc10.i386
Comment 17 Robert Hancock 2008-12-31 17:26:58 EST
Created attachment 328023 [details]
Corrupted font rendering
Comment 18 Robert Hancock 2009-01-04 18:53:19 EST
Problem mentioned in comments 16 and 17 and FreeDesktop.org bug 19363 can be worked around by Option "RenderAccel" "off" in xorg.conf.

Also it does not appear to happen in the latest -git version (with RenderAccel enabled). Maybe something can be backported?
Comment 19 Peter Lemenkov 2009-01-05 02:25:38 EST
Today's git ( d5cb24075928690377fd2dfaa32abfebff9990df ) works for me!
Still yellow echo at the end of the words, but I've got glxgears with 700+ fps and correctly drawтб even in 24-bit color!
Comment 20 François Cami 2009-02-20 14:40:14 EST
DUP of 466369 and 466663

Thank you for the bug report.
This particular bug was fixed and a update package
( xorg-x11-drv-ati-6.9.0-62 )
was published for download.
Please feel free to report any further bugs you find, or
reopen if you still experience the problem.

You can obtain the updated package by typing
'yum update' or using the graphical updater.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 466369 ***

Note You need to log in before you can comment on or make changes to this bug.