Bug 444894 - doesn't properly catch a bad import of the install backend
doesn't properly catch a bad import of the install backend
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-05-01 12:08 EDT by Bill Nottingham
Modified: 2014-03-16 23:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-11 17:10:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-05-01 12:08:49 EDT
Description of problem:

Say you make a typo in yuminstall.py (or any other backend). The import
of this will silently fail, leaving you with a rather blank backend.

This makes the installer work for a while, and then fail later in rather random
ways.

Version-Release number of selected component (if applicable):

rawhide-20080501
Comment 1 Jeremy Katz 2008-05-01 12:34:02 EDT
Yeah, this is due to how it happens in the installclass and there's lots of
handling for bad installclasses.  We should try to make this better for F10
Comment 2 Bug Zapper 2008-05-14 06:29:15 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Chris Lumens 2008-07-11 17:10:07 EDT
Jeremy - looks like you fixed this up with
74399a3bbba4716eaa178b258af9e0e82dec6d97.  Closing.

Note You need to log in before you can comment on or make changes to this bug.