Bug 444903 - [PATCH] Can't generate policy for user application
[PATCH] Can't generate policy for user application
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-05-01 13:15 EDT by Lubomir Rintel
Modified: 2008-05-07 07:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 07:34:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix traceback when generating policy for user application (1.20 KB, text/plain)
2008-05-01 13:15 EDT, Lubomir Rintel
no flags Details
Don't let stderr output clobber various lists (1.30 KB, text/plain)
2008-05-01 13:29 EDT, Lubomir Rintel
no flags Details
Necessary changes to SPEC file, fix -gui Requires (1.97 KB, text/plain)
2008-05-01 13:34 EDT, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2008-05-01 13:15:48 EDT
Description of problem:

** (selinux-polgengui:21402): WARNING **: keyboard grab failed: keyboard already
grabbed by another window
/usr/share/system-config-selinux/polgengui.py:354: DeprecationWarning: raising a
string exception is deprecated
  raise(_("You must select a user"))
Traceback (most recent call last):
  File "/usr/share/system-config-selinux/polgengui.py", line 299, in forward
    self.generate_policy()
  File "/usr/share/system-config-selinux/polgengui.py", line 384, in generate_policy
    my_policy=polgen.policy(self.get_name(), self.get_type())
  File "/usr/share/system-config-selinux/polgengui.py", line 354, in get_name
    raise(_("You must select a user"))
You must select a user

Version-Release number of selected component (if applicable):

policycoreutils-gui-2.0.46-5.fc9.i386

Additional info:

See the attached patch for more information.
Comment 1 Lubomir Rintel 2008-05-01 13:15:48 EDT
Created attachment 304322 [details]
Fix traceback when generating policy for user application
Comment 2 Lubomir Rintel 2008-05-01 13:29:27 EDT
Created attachment 304324 [details]
Don't let stderr output clobber various lists

I'll reuse this bug for some more problems, since they have to be fixed at the
same time, contain the fix, and should be fixed at the same time.
Comment 3 Lubomir Rintel 2008-05-01 13:34:25 EDT
Created attachment 304325 [details]
Necessary changes to SPEC file, fix -gui Requires

And at last changes to SPEC file. Note the missing dependency which would cause
selinux-polgenui misbehave silently.

I did not commit these myself, because I really don't know any Python at all,
so I'd be glad if you reviewed whether I haven't broken anything.

Thanks.
Comment 4 Bill Nottingham 2008-05-02 17:39:12 EDT
At this point, I'm not seeing this as a release blocking issue. Moving to F9-target.
Comment 5 Daniel Walsh 2008-05-07 07:34:31 EDT
Fixed in policycoreutils-2.0.47-1

Note You need to log in before you can comment on or make changes to this bug.