Bug 444910 - If /boot isn't mounted, shouldn't yum mount it when doing kernel updates?
If /boot isn't mounted, shouldn't yum mount it when doing kernel updates?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 14:34 EDT by Jerry Lumpkins
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-01 15:37:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry Lumpkins 2008-05-01 14:34:21 EDT
Description of problem:
I have /etc/fstab set to not mount /boot automatically.
If I forget to mount it prior to running yum, and there's a kernel update,
It installs kernel images in the /boot directory, and doesn't update grub.conf
(for obvious reasons...)

Version-Release number of selected component (if applicable):
I've noticed this on a i686 system, but my guess is I'll find it on my x86_64 

How reproducible:
Always.

Steps to Reproduce:
1. Change the /etc/fstab line for the /boot partition to:
LABEL=/boot             /boot                   ext3    noauto          1 2
2. Run yum update when a new kernel is being pushed down.
3. It puts the kernal image and other files that would go into the boot
partition into /boot, and does nothing to grub. It also doesn't appear to report
any errors.
  
Actual results:


Expected results:


Additional info:
It seems like the update process for kernel installs should check to see if the
boot partition is mounted, and if not, try to mount it. (I like to keep it
unmounted so that it handles irregular shutdowns better since it isn't a
journaled file system...
Comment 1 Jerry Lumpkins 2008-05-01 14:40:32 EDT
ah... I just noticed that the boot partition is an ext3...
Comment 2 Seth Vidal 2008-05-01 15:37:02 EDT
yah. this isn't a bug.


Note You need to log in before you can comment on or make changes to this bug.