Bug 444924 - Sound lag issues with pulseaudio
Sound lag issues with pulseaudio
Status: CLOSED DUPLICATE of bug 444388
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 19:46 EDT by Christopher Tubbs
Modified: 2008-10-24 16:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 16:36:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Tubbs 2008-05-01 19:46:29 EDT
+++ This bug was initially created as a clone of Bug #444388 +++

Description of problem:

Sounds lag while playing armacycles-ad/armagetron-ad. All possible variations of
quality / buffer size / sound sources tried, with no significant improvement.
(Low quality lags the least, but sounds horrific).
For example, certain sound effects, such as turning, don't play right away, and
appear to be buffered one after another, so that shortly into the game, this
"sound lag" for the turning quickly becomes a sort of constant, repetitive,
ticking sound. Even if only two people turn at the same time, it sounds like a
"tick-tick" one after another.
This issue did NOT occur in Fedora 7, but I have noticed the problem in Fedora 8
(i386 AND x86_64), and Fedora 9 (Pre-release, i386), so I'm pretty sure it's a
PulseAudio related bug.

Version-Release number of selected component (if applicable):

armacycles-ad-0.2.8.2.1-6.fc9.i386

output of rpm -qa | grep SDL (in case it's relevant)
SDL_sound-1.0.1-9.fc9.i386
SDL_image-1.2.6-6.fc9.i386
SDL_mixer-1.2.8-8.fc9.i386
SDL-1.2.13-3.fc9.i386

output of rpm -qa | grep pulseaudio (in case it's relevant)
pulseaudio-utils-0.9.10-1.fc9.i386
pulseaudio-core-libs-0.9.10-1.fc9.i386
pulseaudio-libs-0.9.10-1.fc9.i386
pulseaudio-0.9.10-1.fc9.i386
akode-pulseaudio-2.0.2-5.fc9.i386
pulseaudio-libs-glib2-0.9.10-1.fc9.i386
alsa-plugins-pulseaudio-1.0.16-4.fc9.i386
pulseaudio-esound-compat-0.9.10-1.fc9.i386
kde-settings-pulseaudio-4.0-21.fc9.noarch
pulseaudio-libs-zeroconf-0.9.10-1.fc9.i386
pulseaudio-module-x11-0.9.10-1.fc9.i386
pulseaudio-module-jack-0.9.10-1.fc9.i386
xine-lib-pulseaudio-1.1.12-2.fc9.i386
pulseaudio-module-zeroconf-0.9.10-1.fc9.i386
pulseaudio-module-gconf-0.9.10-1.fc9.i386

How reproducible:
100%

Steps to Reproduce:
1. Install armacycles-ad into "clean" Fedora 8 or 9 install (currently confirmed
with Fedora 9 pre-release, haven't tried Fedora 8 recently)
2. Play multi-player Internet game (most noticeable in multi-player Internet
game, but still tiny bit of delay with sounds in single player local game).
3. Turn and listen to sound effects.
  
Actual results:
Sound effects seem to be buffered (queued) and played one after another,
resulting in a constant repetitive ticking.

Expected results:
Sound effects should play right away when turning, and not delayed until a
previous effect has completed.

Additional info:
Hardware I'm using is snd_hda_intel (ICH7)

output of /sbin/lspci (if needed; NOTE: I'm using a Dell Inspiron E1405)
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML
Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 01)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4
(rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE
Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
02:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)
Comment 1 Bayard R. Coolidge 2008-05-08 22:09:08 EDT
Symptoms seem to be similar to BZ 441063 that I entered on 5 April. I had
noticed that, even when testing the sample sounds for the GNOME desktop (and KDE
desktop) event sound effects, I had to wait for one clip to finish playing then
wait a few seconds for the ensuing low-level hiss to cease, before playing the
next clip.
Comment 2 Bug Zapper 2008-05-14 06:30:00 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Lennart Poettering 2008-10-24 16:36:58 EDT

*** This bug has been marked as a duplicate of bug 444388 ***

Note You need to log in before you can comment on or make changes to this bug.