This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 444937 - need eclipse langpacks included in Fedora
need eclipse langpacks included in Fedora
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Sean Flanigan
Fedora Extras Quality Assurance
http://www.eclipse.org/babel/download...
: FutureFeature, i18n
Depends On: 452875 458626
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-05-02 01:16 EDT by Jens Petersen
Modified: 2008-10-20 01:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 01:57:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-05-02 01:16:37 EDT
Description of problem:
Fedora Eclipse currently does not ship with any translations/langpacks -
this makes eclipse hard to use for international users.

Steps to Reproduce:
1. Run eclipse in a non-English locale on a non-English install
  
Actual results:
1. UI appears in English

Expected results:
1. Eclipse to appear in native language.

Additional info:
I install Japanese langpacks from the Eclipse Babel project and after restarting
eclipse was running in Japanese.
Comment 1 Andrew Overholt 2008-05-02 08:47:56 EDT
IBM used to provide langpacks for 3.2 and earlier.  They stopped for 3.3.  We're
hopefully moving to 3.4 for F10 so we can investigate the Babel-provided
langpacks at that time.
Comment 2 Jens Petersen 2008-07-01 01:25:26 EDT
Would they become part of the main package or go into a separate source package?
Comment 3 Andrew Overholt 2008-07-02 09:40:54 EDT
They would go into a separate source package like we used to have
(eclipse-sdk-nls was the name, I think).

I'm working on getting Eclipse 3.4 into rawhide.  You can track progress here:

https://fedoraproject.org/wiki/Features/Eclipse34

Note that I'm not sure if I'm going to have the time to do the langpack stuff
myself.  Perhaps I can point you or someone in the right direction and help a bit?
Comment 4 Jens Petersen 2008-07-02 21:50:22 EDT
You're right I see there was a eclipse-sdk-nls package in F7.

(In reply to comment #3)
> Note that I'm not sure if I'm going to have the time to do the langpack stuff
> myself.  Perhaps I can point you or someone in the right direction and help a bit?

Sure, then I will try to get someone in the i18n team here to assist with that.

I think there are already langpacks for Europa, right?  So maybe it is better
we start preparing the langpack packaging now while you work on Ganymede,
and then it should be easy to update them when that is ready?  How does that sound?

What would the best name for the new langpacks source package be?  Maybe
eclipse-nls?
Comment 5 Andrew Overholt 2008-07-03 10:23:35 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > Note that I'm not sure if I'm going to have the time to do the langpack stuff
> > myself.  Perhaps I can point you or someone in the right direction and help
a bit?
> 
> Sure, then I will try to get someone in the i18n team here to assist with that.

Awesome!  I haven't finished with changing the way we'll package things for
Ganymede so don't worry about making RPMs yet.

> I think there are already langpacks for Europa, right?

Not from IBM.

> So maybe it is better
> we start preparing the langpack packaging now while you work on Ganymede,
> and then it should be easy to update them when that is ready?  How does that
sound?

Well, if you can find Babel langpacks that work with 3.3.2 (Europa), sure, try
them.  The process will change _slightly_ for 3.4 (Ganymede) but I can
definitely help with that.

> What would the best name for the new langpacks source package be?  Maybe
> eclipse-nls?

What do we call other langpack SRPMs?  In Fedora 7 we tried to follow the common
way of doing things (we had to write a munger to take the IBM-provided langpacks
and turn them into per-language (for all Eclipse components) instead of
per-Eclipse component (for all languages)).  I'll let you decide on that for the
future since you know best :)
Comment 6 Jens Petersen 2008-07-03 23:23:54 EDT
> Well, if you can find Babel langpacks that work with 3.3.2 (Europa), sure, try
> them.  The process will change _slightly_ for 3.4 (Ganymede) but I can
> definitely help with that.

Ok thanks

> What do we call other langpack SRPMs?

So the Babel project names their files like
org.eclipse.nls.ja_0.2.0.v20080629043401.jar
(http://download.eclipse.org/technology/babel/update-site/europa/) so I guess
either eclipse-nls or preferably IMHO eclipse-langpack for the source package.
Then subpackages would be eclipse-langpack-ja (eclipse-nls-ja), etc.
Comment 7 Andrew Overholt 2008-07-04 14:55:53 EDT
Okay, whatever you want.  If we could somehow Obsolete/Provide the previous
eclipse-sdk-nls packages, that would be cool.
Comment 8 Sean Flanigan 2008-07-23 23:17:43 EDT
From my testing, and from reading on the Eclipse news server, it looks as if the
Babel langpacks tend to break the P2 update manager in some cases (eg
https://bugs.eclipse.org/bugs/show_bug.cgi?id=238800 ).

I see a similar problem (flashing splash screen; Eclipse restarting over and
over) when dumping a langpack under eclipse/dropins and subsequently installing
the same langpack via the Babel update site in P2.

However, putting a langpack under eclipse/dropins does work as long as you don't
use the update site from Eclipse, so it's not a complete show-stopper, at least
during development.
Comment 9 Tony Fu 2008-09-09 23:15:42 EDT
requested by Jens Petersen (#27995)
Comment 10 Jens Petersen 2008-09-29 21:19:44 EDT
eclipse-nls that provides babel langpacks have been in rawhide now for a few weeks.
I added them to comps-f10 yesterday too.

However because of bug 458626 they are still not working consistently.

Note You need to log in before you can comment on or make changes to this bug.