Bug 444938 - conga fails to create proper cluster.conf entries for gfs2 filesystem type
conga fails to create proper cluster.conf entries for gfs2 filesystem type
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Ryan McCabe
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-02 01:23 EDT by Vedanta Barooah
Modified: 2009-04-16 18:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:56:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vedanta Barooah 2008-05-02 01:23:26 EDT
Description of problem: when a new logical volume group is created using conga
of fstype gfs2 the cluster.conf clusterfs element is marked as gfs instead. due
to this misconfiguration gfs2 file systems fail to mount when services fail over
to other nodes. 


Version-Release number of selected component (if applicable): luci-0.10.0-6.el5


How reproducible: 

Steps to Reproduce:
1. create a gfs2 lv
2. make it a resource
3. add the resource to a service
4. assign service to node
5. try failing over the service
  
Actual results: service failover failure due to node not being able to mount gfs
2 volume


Expected results: proper service failover

Additional info: can be corrected by changing fstype to gfs2 in cluster.conf
Comment 3 Tim Wilkinson 2008-10-14 14:42:02 EDT
Reproduced bug using luci-0.12.0.7.el5
Comment 4 Brian Brock 2008-12-16 18:28:32 EST
bugfix verified in luci-0.12.1-7.el5, cluster.conf appears to be correct
Comment 6 errata-xmlrpc 2009-01-20 16:56:50 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0196.html

Note You need to log in before you can comment on or make changes to this bug.