Bug 444953 - Add support for a conf.d directory
Add support for a conf.d directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lighttpd (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-02 06:11 EDT by David Dick
Modified: 2008-12-22 11:22 EST (History)
0 users

See Also:
Fixed In Version: 1.4.20-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 11:22:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to include conf.d support for lighttpd (281 bytes, patch)
2008-05-02 06:11 EDT, David Dick
no flags Details | Diff

  None (edit)
Description David Dick 2008-05-02 06:11:41 EDT
Description of problem:

/etc/lighttpd/lighttpd.conf provides no interface for packaging a web
application for lighttpd.  By convention this is done by providing a conf.d
directory.

Version-Release number of selected component (if applicable): 1.4.19-4.fc8


How reproducible:


Steps to Reproduce:
1. examine /etc/lighttpd/lighttpd.conf
2. search for conf.d directory
3.
  
Actual results:

no conf.d directory capability is observable

Expected results:

patch included. background discussion from lighttpd developers at
http://trac.lighttpd.net/trac/ticket/1221

Additional info:
Comment 1 David Dick 2008-05-02 06:11:41 EDT
Created attachment 304372 [details]
Patch to include conf.d support for lighttpd
Comment 2 Bug Zapper 2008-05-14 06:30:39 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matthias Saou 2008-12-22 11:22:11 EST
Added in 1.4.20-2, only in devel for now. Note that from my testing, this makes it quite hard to find the errors in the conf.d/*.conf files since lighttpd reports the error as being on the include_shell line from the main configuration. But I understand how useful this can be, which is why I've included the change.

Note You need to log in before you can comment on or make changes to this bug.