Bug 444956 - kmail crash
kmail crash
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-02 06:46 EDT by Juha Tuomala
Modified: 2008-05-02 10:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 08:48:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 161523 None None None Never

  None (edit)
Description Juha Tuomala 2008-05-02 06:46:08 EDT
Description of problem:
 run --nofork
Starting program: /usr/bin/kmail --nofork
[Thread debugging using libthread_db enabled]
[New Thread 0xb801f8e0 (LWP 3243)]
[New Thread 0xb7cc4b90 (LWP 3264)]
[New Thread 0xb72c3b90 (LWP 3265)]
[New Thread 0xb68c2b90 (LWP 3266)]
[New Thread 0xb5ec1b90 (LWP 3267)]
WeaverThreadLogger: thread (ID: 1) suspended.
WeaverThreadLogger: thread (ID: 2) suspended.
WeaverThreadLogger: thread (ID: 3) suspended.
WeaverThreadLogger: thread (ID: 4) suspended.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb801f8e0 (LWP 3243)]
KMFolder::isOpened (this=Could not find the frame base for "KMFolder::isOpened()
const".
) at kmfolder.cpp:495
495     bool KMFolder::isOpened() const
Missing separate debuginfos, use: debuginfo-install acl.i386 attr.i386
expat.i386 fontconfig.i386 freetype.i386 gcc.i386 glibc.i686 gpgme.i386
lcms.i386 libICE.i386 libSM.i386 libX11.i386 libXau.i386 libXcursor.i386
libXdmcp.i386 libXext.i386 libXfixes.i386 libXft.i386 libXi.i386
libXinerama.i386 libXrandr.i386 libXrender.i386 libart_lgpl.i386
libgpg-error.i386 libidn.i386 libjpeg.i386 libmng.i386 libpng.i386
libutempter.i386 libxcb.i386 pcre.i386 qt3.i386 zlib.i386
(gdb) bt
#0  KMFolder::isOpened (this=Could not find the frame base for
"KMFolder::isOpened() const".
) at kmfolder.cpp:495
#1  0x0617559d in KMMainWidget::slotCompactFolder (this=<value optimized out>)
    at kmmainwidget.cpp:1304
#2  0x0618ff5a in KMMainWidget::qt_invoke (this=<value optimized out>,
    _id=<value optimized out>, _o=Could not find the frame base for
"KMMainWidget::qt_invoke(int, QUObject*)".
) at kmmainwidget.moc:538
#3  0x04c13bda in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#4  0x04c156eb in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3

#5  0x0531fe39 in KAction::activated (this=Could not find the frame base for
"KAction::activated()".
) at kaction.moc:176
#6  0x05369960 in KAction::slotActivated (this=<value optimized out>)
    at kaction.cpp:1102
#7  0x0540f175 in KAction::slotPopupActivated (this=<value optimized out>)
    at kaction.cpp:1137
#8  0x0540f4a0 in KAction::qt_invoke (this=<value optimized out>,
    _id=<value optimized out>, _o=Could not find the frame base for
"KAction::qt_invoke(int, QUObject*)".
) at kaction.moc:219
#9  0x04c13bda in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#10 0x04fac54c in QSignal::signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#11 0x04c3378d in QSignal::activate () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#12 0x04d3871c in QPopupMenu::mouseReleaseEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#13 0x0534cbe2 in KPopupMenu::mouseReleaseEvent (this=<value optimized out>,
    e=<value optimized out>) at kpopupmenu.cpp:508
#14 0x04c50e71 in QWidget::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#15 0x04baadf5 in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#16 0x04bac16f in QApplication::notify () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#17 0x03eab922 in KApplication::notify (this=<value optimized out>,
    receiver=<value optimized out>, event=<value optimized out>)
    at kapplication.cpp:550
#18 0x04b426be in QApplication::sendSpontaneousEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#19 0x04b4243f in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#20 0x04b4136a in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x04b533cb in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x04bc54f0 in QEventLoop::enterLoop () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#23 0x04bab43f in QApplication::enter_loop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#24 0x04d3b9d4 in QPopupMenu::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
---Type <return> to continue, or q <return> to quit---
#25 0x05f67489 in KMFolderTree::slotContextMenuRequested (
    this=<value optimized out>, lvi=<value optimized out>,
    p=<value optimized out>) at kmfoldertree.cpp:1166
#26 0x05f68bc1 in KMFolderTree::qt_invoke (this=<value optimized out>,
    _id=<value optimized out>, _o=Could not find the frame base for
"KMFolderTree::qt_invoke(int, QUObject*)".
) at kmfoldertree.moc:471
#27 0x04c13bda in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#28 0x04fc1810 in QListView::contextMenuRequested ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#29 0x04d16327 in QListView::contentsContextMenuEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#30 0x04d48296 in QScrollView::viewportContextMenuEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#31 0x04d470fb in QScrollView::eventFilter ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#32 0x04d11426 in QListView::eventFilter () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#33 0x05f5e1e9 in KMFolderTree::eventFilter (this=<value optimized out>,
    o=<value optimized out>, e=<value optimized out>) at kmfoldertree.cpp:1720
#34 0x04c13ca3 in QObject::activate_filters ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#35 0x04c13d2b in QObject::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#36 0x04c50cec in QWidget::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#37 0x04baadf5 in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#38 0x04bac79f in QApplication::notify () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#39 0x03eab922 in KApplication::notify (this=<value optimized out>,
    receiver=<value optimized out>, event=<value optimized out>)
    at kapplication.cpp:550
#40 0x04b426be in QApplication::sendSpontaneousEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#41 0x04b42512 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#42 0x04b4136a in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#43 0x04b533cb in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#44 0x04bc54f0 in QEventLoop::enterLoop () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#45 0x04bc53c6 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#46 0x04bab4cf in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#47 0x0804a09e in main (argc=Cannot access memory at address 0xffffffff
) at main.cpp:110
(gdb)

Version-Release number of selected component (if applicable):
kdepimlibs-debuginfo-4.0.3-3.fc9.i386
kdepim-libs-3.5.9-9.fc9.i386
kdepim-3.5.9-9.fc9.i386
kdepimlibs-devel-4.0.3-3.fc9.i386
kdepimlibs-4.0.3-3.fc9.i386
kdepimlibs-apidocs-4.0.3-3.fc9.i386
kdepim-devel-3.5.9-9.fc9.i386
kdepim-debuginfo-3.5.9-9.fc9.i386

How reproducible:

happens sometimes.

Steps to Reproduce:
1. open kmail
2. run 'compact' for a folder when it's checking email
3. crash/hang
Comment 1 Steven M. Parrish 2008-05-02 07:13:57 EDT
Checked upstream for a matching bug, did not find one.  Please file upstream and
add bug info to this report.
Comment 2 Kevin Kofler 2008-05-02 10:46:03 EDT
This sounds like it's missing some icons, it might be a Fedora issue.
Comment 3 Kevin Kofler 2008-05-02 10:56:41 EDT
Disregard comment #2, that's just me being confused. ;-) It's talking about 
debugging frames there, not image frames.

It actually crashes in this simple function, looks like a NULL or invalid 
pointer somewhere:
bool KMFolder::isOpened() const
{
  return mStorage->isOpened();
}

Note You need to log in before you can comment on or make changes to this bug.