This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 444965 - Xen will not boot
Xen will not boot
Status: CLOSED DUPLICATE of bug 437930
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-02 09:11 EDT by David Martos
Modified: 2008-05-04 14:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 09:19:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Martos 2008-05-02 09:11:58 EDT
Description of problem:
System will not boot after installing.

Steps:
In Fedora Core 9 preview. Do a custom install and select components you want,
select Xen kernel, install as normal. At first boot, you will be not able to
boot because error:
kernel /boot/xen.gz-2.6.25-0.24.rc9.fc9.i686
Error 15: File not found

Version-Release number of selected component (if applicable):
Fedora core 9 preview

Solution:
You can edit grub by pressing key e and modify the line like this:
kernel /boot/xen.gz-2.6.25-0.24.rc9.fc9.i686.xen
then the system will boot.
Someone forget to add the .xen extension in the grub menu.

I must also say that my system hangs after loading Xen kernel, last message is:
(XEN) Xen is relinquishing VGA console.
But this problem may not be related to then .xen extension missing.
May be there are more parameters after .xen ?
Comment 1 Daniel Berrange 2008-05-02 09:19:04 EDT
The Xen Dom0 host is *NOT* supported in Fedora 9

http://fedoraproject.org/wiki/Features/XenPvops

It may be re-introduced in FEdora 10

http://fedoraproject.org/wiki/Features/XenPvopsDom0
Comment 2 Mark McLoughlin 2008-05-04 14:48:30 EDT

*** This bug has been marked as a duplicate of 437930 ***

Note You need to log in before you can comment on or make changes to this bug.