Bug 444968 - Copy and Paste does not work when typing the root password
Copy and Paste does not work when typing the root password
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-05-02 09:52 EDT by David Martos
Modified: 2008-07-15 17:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 17:24:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Martos 2008-05-02 09:52:11 EDT
Description of problem:
Copy and Paste doesn't work when the system request that you type the root
password you want before the installation process began.

Version-Release number of selected component (if applicable):
Fedora 9 preview

How reproducible:
Begin installation select language, partitions, and it's on the root password
request step.
  
Actual results:
Type the password, black dots appear on the screen as usual, select copy by
keyboard shortcut or by right mouse button.
Go to confirm box and paste.
Press next and it will say that passwords doesn't match.

Expected results:
I think that copy and paste rigth mouse button menu (and keyboard shortcut) must
be disabled in this step because it confuses user by having an option that does
not work.

Additional info:
The same may happen when encription partition password is requested.
Comment 1 John Poelstra 2008-05-02 18:05:31 EDT
Why do you think this is a bug?  Copying and pasting the password seems to
defeat the process of verifying that you entered the correct password.
Comment 2 David Martos 2008-05-02 19:20:40 EDT
You're right, but it's a common practice.
Another case is if you have a password like: MYPASSWORDMYPASSWORD and you want
to copy and paste in the same first box, it doesn't work.
I just say it must be easy to disable cut and paste in this screen to avoid user
confusion.
Comment 3 Bug Zapper 2008-05-14 06:30:58 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Chris Lumens 2008-07-15 17:24:57 EDT
This is actually due to GTK.  When you highlight the text in the first box,
you're highlighting the bullets.  So then when you go to paste it into the
second box, you're pasting bullets in as the second password.  So of course they
don't match.  Nor do I see any obvious way to disable copy-and-paste for just
these dialogs.  I don't think there's anything we can do here.

Note You need to log in before you can comment on or make changes to this bug.