Bug 444990 - wrong network settings
wrong network settings
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-02 12:16 EDT by Thorsten Scherf
Modified: 2014-03-16 23:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 03:30:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2008-05-02 12:16:34 EDT
Description of problem:
no sure if libvirt is the right product here, but anyway, it'll give it a try.
I use static networking for a kvm host, configured in ifcfg-eth0:

[root@rawhide ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
DEVICE=eth0
BOOTPROTO=static
BROADCAST=192.168.122.255
HWADDR=00:16:3e:68:4a:fe
IPADDR=192.168.122.130
NETMASK=255.255.255.0
NETWORK=192.168.122.0
ONBOOT=yes
[root@rawhide ~]# 

when I check the ip settings, a wrong address has been assigned to the host:

[root@rawhide ~]# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:16:3E:68:4A:FE  
          inet addr:192.168.122.132  Bcast:192.168.122.255  Mask:255.255.255.0
          inet6 addr: fe80::216:3eff:fe68:4afe/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:238169 errors:0 dropped:0 overruns:0 frame:0
          TX packets:136215 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:324199411 (309.1 MiB)  TX bytes:10555465 (10.0 MiB)
          Interrupt:11 Base address:0xa000 

[root@rawhide ~]# 

this happens directly after a fresh restart of the machine. no dhcp involved.

Version-Release number of selected component (if applicable):
libvirt-0.4.2-1.fc9.i386

How reproducible:
reboot the machine, check ip settings

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bug Zapper 2008-05-14 06:31:45 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Mark McLoughlin 2009-01-21 05:00:40 EST
Hmm, looks like DHCP is getting run on the iface somehow
Comment 3 Bill Nottingham 2009-01-21 13:28:00 EST
What's the output of:

chkconfig --list network
chkconfig --list NetworkManager

?
Comment 4 lexual 2009-03-03 18:40:28 EST
Can the reporter please confirm if this bug is still current?
Can the reporter please answer Bill's question.
Comment 5 Thorsten Scherf 2009-03-04 03:30:58 EST
haven't seen this again.

will close this bug.

Note You need to log in before you can comment on or make changes to this bug.