Bug 444995 - inittab needs to be fixed before release
inittab needs to be fixed before release
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-02 12:49 EDT by David Wilson
Modified: 2014-03-16 23:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 12:55:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log (25.28 KB, text/plain)
2008-05-03 10:47 EDT, David Wilson
no flags Details
yum upgrade log (12.36 KB, text/plain)
2008-05-05 12:59 EDT, David Wilson
no flags Details

  None (edit)
Description David Wilson 2008-05-02 12:49:26 EDT
Description of problem:


Version-Release number of selected component (if applicable):
FC9-Preview

How reproducible:
Very

Steps to Reproduce:
1. kill any text tty
2. It doesnt restart
3. Look at inittab in /etc to see what is missing
  
Actual results:
It's broke!

Expected results:
Text ttys don't respawn.  They should.


Additional info:

This is the only relevant line in the FC9-preview inittab file:

id:5:initdefault:


It needs these lines:


# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit

l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6

# Trap CTRL-ALT-DELETE
ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# When our UPS tells us power has failed, assume we have a few minutes
# of power left.  Schedule a shutdown for 2 minutes from now.
# This does, of course, assume you have powerd installed and your
# UPS connected and working correctly.  
pf::powerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

# If power was restored before the shutdown kicked in, cancel it.
pr:12345:powerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"


But Wait... there is more...

I would suggest going back to any recent flavor and copying the rest of the
inittab file.  

This needs to be fixed before release of FC9
Comment 1 Bill Nottingham 2008-05-02 12:55:55 EDT
Please read the comments at the top of the inittab file.
Comment 2 David Wilson 2008-05-02 13:01:08 EDT
Since the text screens don't reinitialize, could you please send a clue bat so I
can fix it to use the text screens without having to reinit the ttys?  Where did
that go?
Comment 3 Bill Nottingham 2008-05-02 13:10:49 EDT
How did you upgrade?
Comment 4 David Wilson 2008-05-02 21:33:43 EDT
This box was upgraded with the FC9 Preview live iso last Friday (Apr 25).  Only
partition that was kept as is was the /home partition.  
Comment 5 David Wilson 2008-05-03 10:47:04 EDT
Created attachment 304459 [details]
anaconda log

This was the install log from another machine with the same problem.
Comment 6 Bill Nottingham 2008-05-05 12:02:37 EDT
I need upgrade.log as well; it should be in a similar place on the filesystem.
Comment 7 David Wilson 2008-05-05 12:59:03 EDT
Created attachment 304540 [details]
yum upgrade log
Comment 8 Bill Nottingham 2008-05-05 13:04:02 EDT
OK, I *believe* this is due to event-compat-sysv accidentally still being in the
tree. This should be fixed when upgrading to F9 final.

Note You need to log in before you can comment on or make changes to this bug.