This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 444996 - glibc cacoshl() miscompiled by gcc-4.3
glibc cacoshl() miscompiled by gcc-4.3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
9
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-05-02 12:59 EDT by Bill Nottingham
Modified: 2014-03-16 23:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-30 12:08:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 36090 None None None Never

  None (edit)
Description Bill Nottingham 2008-05-02 12:59:09 EDT
Description of problem:

See: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=36090

Version-Release number of selected component (if applicable):

glibc-2.8-2
Comment 1 Will Woods 2008-05-05 11:05:24 EDT
Should be fixed in glibc-2.8-3. Build available here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=48111
Comment 2 Will Woods 2008-05-08 12:37:17 EDT
Can someone verify the fix, or give me a suggestion about how to verify it?
Comment 3 Jakub Jelinek 2008-05-08 12:51:32 EDT
It wasn't fixed, just worked around.  The real fix is being checked into GCC
today, so too late for F9.
Anyway, to verify cacoshl etc., just look for
build-ppc64-linuxnptl/math/test-ldouble.out
and
build-ppc64-linuxnptl/math/test-ildoubl.out
in TESTING DETAILS in glibc 2.8-2 vs. 2.8-3 ppc64 build.log.
In 2.8-2 you will see a lot of errors, in 2.8-3 it isn't present (because the
test succeeded).
On ppc/ppc64 you need to ignore all the power6/ failures, because the lame koji
buildboxes don't have Altivec support, to get a clean testing you need to build
on Power6 or at least some Power box with Altivec ISA (e.g. G5).
Comment 4 Will Woods 2008-05-09 16:25:53 EDT
Thanks for the info, Jakub. Since we have a workaround in F9 I'm going to move
this off the blocker list.

I'm moving it to F9Target, under the assumption that the real fix will show up
as a F9 update.
Comment 5 Bug Zapper 2008-05-14 06:32:11 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Ulrich Drepper 2008-12-30 12:08:50 EST
The new gcc has long been deployed.  Closing.

Note You need to log in before you can comment on or make changes to this bug.