Bug 444999 - samba/winbind - Receiving SMB: Server stopped responding
samba/winbind - Receiving SMB: Server stopped responding
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba (Show other bugs)
All Linux
low Severity medium
: rc
: ---
Assigned To: Simo Sorce
Depends On:
  Show dependency treegraph
Reported: 2008-05-02 13:24 EDT by Jim McKown
Modified: 2008-12-17 13:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-12-17 13:39:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 4973 None None None Never

  None (edit)
Description Jim McKown 2008-05-02 13:24:11 EDT
Description of problem:  When a samba server is configured as a PDC, with samba
version 3.0.25b, the following message is logged over and over again in smb.log:
 "libsmb/clientgen.c:cli_receive_smb(112)   Receiving SMB: Server stopped
responding".  The log entry is repeated 3 times in quick succession, and the
cycle repeats every 5 minutes.  Also, client machines take a long time to
connect to samba shared resources (often 30 seconds or longer).  This is a known
samba bug that has been resolved as of samba release 3.0.28a (please see thread
at https://bugzilla.samba.org/show_bug.cgi?id=4973 ).  Is the fix for this issue
in the stream for rhel4/5?  

Version-Release number of selected component (if applicable):

How reproducible: always/continuous

Steps to Reproduce:
1. Install samba 3.0.25b via rpm and configure as PDC.
2. Have Windows XP/Vista clients connect to samba shares.
3. Examine smb.log
Actual results:  Many "server stopped responding" entries in smb.log.  Many
instances of very long connection times.

Expected results:  Server doesn't stop responding.  Clients can connect in a
reasonable amount of time.

Additional info:
Comment 1 Simo Sorce 2008-05-02 14:10:43 EDT
Yes should be fixed in the next update release of RHEL4 and RHEL5. Beta packages
are available for testing.
Comment 2 Jim McKown 2008-05-02 14:33:14 EDT
Great! Where can I get the beta for the samba packages?
Comment 3 Simo Sorce 2008-05-02 14:52:12 EDT
Through RHN channel.

Note You need to log in before you can comment on or make changes to this bug.