Bug 445004 - Segmentation fault in glutInitDisplayMode
Summary: Segmentation fault in glutInitDisplayMode
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: PyOpenGL   
(Show other bugs)
Version: 9
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Nikolay Vladimirov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-02 18:01 UTC by Michael Krauss
Modified: 2008-07-26 21:21 UTC (History)
0 users

Fixed In Version: 3.0.0-0.6.b4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-26 21:21:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Krauss 2008-05-02 18:01:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
When starting a program using glutInitDisplayMode(), no matter what parameters passed, it results in a segmentation fault. This program for example:
http://aspn.activestate.com/ASPN/Cookbook/Python/Recipe/325391/index_txt
or the test_glutinit.py program from the original pyopengl upstream package.


Version-Release number of selected component (if applicable):
PyOpenGL-3.0.0-0.5.b1.fc9.noarch

How reproducible:
Always


Steps to Reproduce:
1. try to start one of the mentioned programs.


Actual Results:
segmentation fault. No error messages bedside that.

Expected Results:
A beautiful OpenGl rendered window should appear.

Additional info:

Comment 1 Bug Zapper 2008-05-14 10:32:23 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Nikolay Vladimirov 2008-07-18 10:51:21 UTC
I'm not able to reprodce this. 
A new version of PyOpenGl will hit tomorrow's rawhide try with that. Also it
will be in F-9 updates-testing in a few days. 
So, please try the new version and report if the problem is still present or not. 

Comment 3 Nikolay Vladimirov 2008-07-26 21:21:39 UTC

No reply from the reporter. I'm closing this if the problem is still present,
please reopen the bug. 


Note You need to log in before you can comment on or make changes to this bug.