Bug 445014 - grub.efi needs to read MSDOS partition type 0xEF EFI System
grub.efi needs to read MSDOS partition type 0xEF EFI System
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 445015
  Show dependency treegraph
 
Reported: 2008-05-02 14:52 EDT by Matt Domsch
Modified: 2009-05-05 17:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 17:14:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2008-05-02 14:52:13 EDT
Description of problem:
grub doesn't belief partition type 0xEF is a valid FAT file system type for
reading.  it should, for EFI systems.

Version-Release number of selected component (if applicable):
grub-0.97-33.fc9.x86_64
Comment 1 Bug Zapper 2008-05-14 06:32:43 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Matt Domsch 2008-08-06 12:03:10 EDT
pjones, I know we worked out a patch for this.  Where did it go?
Comment 3 Vaclav "sHINOBI" Misek 2009-03-31 06:35:21 EDT
Is it solved by the grub-0.97-44.fc11 package from todays Rawhide?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Jeremy Katz 2009-05-04 15:02:59 EDT
Matt -- is this in now or do I need to hunt it down?
Comment 5 Matt Domsch 2009-05-04 17:25:39 EDT
not sure, looks like it from the changelog.  Stuart has been doing the EFI testing, so reassigning NEEDINFO to him. :-)
Comment 6 Stuart Hayes 2009-05-05 17:07:42 EDT
I just used grub (0.97-47) to boot to a disk that an MBR partition table, with one partition of type 0xEF, and it worked, so I guess this is fixed.
Comment 7 Jeremy Katz 2009-05-05 17:14:27 EDT
Thanks Stuart

Note You need to log in before you can comment on or make changes to this bug.