Bug 445041 - plugging in iPhone crashes gvfsd-gphoto2
plugging in iPhone crashes gvfsd-gphoto2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-02 17:39 EDT by Tom London
Modified: 2015-03-03 17:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 07:45:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of popups when connecting iPhone (117.93 KB, image/png)
2008-05-05 15:50 EDT, Tom London
no flags Details
gthumb popup (9.69 KB, image/png)
2008-05-05 15:50 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2008-05-02 17:39:31 EDT
Description of problem:
I see this in /var/log/messages when plugging in iPhone (I connect it to WinXP
client running in VMWare):

May  2 11:12:40 localhost kernel: usb 1-6.1: new high speed USB device using
ehci_hcd and address 10
May  2 11:12:40 localhost kernel: usb 1-6.1: configuration #1 chosen from 3 choices
May  2 11:12:40 localhost kernel: usb 1-6.1: New USB device found,
idVendor=05ac, idProduct=1290
May  2 11:12:40 localhost kernel: usb 1-6.1: New USB device strings: Mfr=1,
Product=2, SerialNumber=3
May  2 11:12:40 localhost kernel: usb 1-6.1: Product: iPhone
May  2 11:12:40 localhost kernel: usb 1-6.1: Manufacturer: Apple Inc.
May  2 11:12:40 localhost kernel: usb 1-6.1: SerialNumber:
5aadff906560b2de9d885c299dd5256d4fa11866
May  2 11:12:41 localhost kernel: printk: 1 messages suppressed.
May  2 11:12:41 localhost kernel: gvfsd-gphoto2[14143]: segfault at c ip
00cda7a0 sp bfea5e0c error 4 in libpthread-2.8.so[cd3000+15000]

Is there some way to capture more info?

Version-Release number of selected component (if applicable):
gvfs-0.2.3-11.fc9.i386

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Clasen 2008-05-05 12:19:30 EDT
David, you have an iphone, right ?
Comment 2 David Zeuthen 2008-05-05 12:45:23 EDT
Yes, this works nicely for me. Please see if the device works with the gphoto2
commandline tool, e.g 'gphoto2 -L' or similar.
Comment 3 Tom London 2008-05-05 12:54:18 EDT
Hmmmm

[tbl@localhost ~]$ gphoto2 -L
                                                                               
*** Error ***              
An error occurred in the io-library ('Could not lock the device'): Camera is
already in use.
*** Error (-60: 'Could not lock the device') ***       

For debugging messages, please use the --debug option.
Debugging messages may help finding a solution to your problem.
If you intend to send any error or debug messages to the gphoto
developer mailing list <gphoto-devel@lists.sourceforge.net>, please run
gphoto2 as follows:

    env LANG=C gphoto2 --debug --debug-logfile=my-logfile.txt -L

Please make sure there is sufficient quoting around the arguments.

[tbl@localhost ~]$ 

After "unmounting" the iPhone (right click on Desktop icon):
[tbl@localhost ~]$ gphoto2 -L
There is no file in folder '/'.                                                
There is no file in folder '/store_00010002'.
There is no file in folder '/store_00010002/DCIM'.
There are 5 files in folder '/store_00010002/DCIM/100APPLE'.
#1     IMG_0001.JPG                  597 KB image/jpeg
#2     IMG_0002.JPG                  401 KB image/jpeg
#3     IMG_0003.JPG                  513 KB image/jpeg
#4     IMG_0004.JPG                  448 KB image/jpeg
#5     IMG_0005.JPG                  352 KB image/jpeg
[tbl@localhost ~]$ 
Comment 4 Tom London 2008-05-05 12:55:56 EDT
Connecting the iPhone appears to produce inconsistent behavior.

Sometimes I get nothing but the iPhone icon on the desktop.

Once I got prompted to pick the app to use to display photos (f-spot or gthumb?)

Most times I do not get the segfault.
Comment 5 David Zeuthen 2008-05-05 13:00:54 EDT
(In reply to comment #4)
> Connecting the iPhone appears to produce inconsistent behavior.
> 
> Sometimes I get nothing but the iPhone icon on the desktop.
> 
> Once I got prompted to pick the app to use to display photos (f-spot or gthumb?)
> 
> Most times I do not get the segfault.

If it's mounted it means the gphoto2 backend is working... It would be useful to
get strack traces of when it crashes but unfortunately bug buddy don't do that
automatically :-/
Comment 6 Tom London 2008-05-05 15:50:05 EDT
Created attachment 304552 [details]
screenshot of popups when connecting iPhone

Plugging in the iPhone, I get the following messages:

May  5 12:43:47 localhost kernel: usb 1-6.1: new high speed USB device using
ehci_hcd and address 8
May  5 12:43:47 localhost kernel: usb 1-6.1: configuration #1 chosen from 3
choices
May  5 12:43:47 localhost kernel: usb 1-6.1: New USB device found,
idVendor=05ac, idProduct=1290
May  5 12:43:47 localhost kernel: usb 1-6.1: New USB device strings: Mfr=1,
Product=2, SerialNumber=3
May  5 12:43:47 localhost kernel: usb 1-6.1: Product: iPhone
May  5 12:43:47 localhost kernel: usb 1-6.1: Manufacturer: Apple Inc.
May  5 12:43:47 localhost kernel: usb 1-6.1: SerialNumber:
5aadff906560b2de9d885c299dd5256d4fa11866
May  5 12:43:51 localhost kernel: printk: 1 messages suppressed.
May  5 12:43:51 localhost kernel: gvfsd-gphoto2[8562]: segfault at c ip
00cda7a0 sp bff3b91c error 4 in libpthread-2.8.so[cd3000+15000]

and the attached popup warnings.

I attach below the popup I get when I click on the "open with gThumb" button.
Comment 7 Tom London 2008-05-05 15:50:32 EDT
Created attachment 304553 [details]
gthumb popup
Comment 8 Bug Zapper 2008-05-14 06:33:36 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Anthony Green 2008-06-11 13:51:22 EDT
I get a similar result when I plug in my digital camera:

Jun 11 10:32:38 laptop kernel: usb 1-4: new high speed USB device using ehci_hcd
and address 11
Jun 11 10:32:38 laptop kernel: usb 1-4: configuration #1 chosen from 1 choice
Jun 11 10:32:38 laptop kernel: usb 1-4: New USB device found, idVendor=04a9,
idProduct=3160
Jun 11 10:32:38 laptop kernel: usb 1-4: New USB device strings: Mfr=1,
Product=2, SerialNumber=3
Jun 11 10:32:38 laptop kernel: usb 1-4: Product: Canon Digital Camera
Jun 11 10:32:38 laptop kernel: usb 1-4: Manufacturer: Canon Inc.
Jun 11 10:32:38 laptop kernel: usb 1-4: SerialNumber:
417070BA871D41F686F4E01052E670AF
Jun 11 10:32:39 laptop kernel: gvfsd-gphoto2[20624]: segfault at c ip 0045c7a0
sp bfa7043c error 4 in libpthread-2.8.so[455000+15000]
Jun 11 10:32:40 laptop kernel: gvfsd-gphoto2[20638]: segfault at c ip 0045c7a0
sp bf84d08c error 4 in libpthread-2.8.so[455000+15000]
Comment 10 David Zeuthen 2008-06-11 15:23:52 EDT
(In reply to comment #9)
> I get a similar result when I plug in my digital camera:

Does gphoto2(1) (e.g. with option -L, similar) work on the camera? Does this
crash happen every time or only intermittently? Any chance you obtain a stack
trace? [1]

IIRC some shared gvfs code saw a few bug fixes so please also try this with the
latest gvfs package in F9. Thanks.

[1] : The easiest way to do this is as follows

 $ gdb --args /usr/libexec/gvfsd-gphoto2 host=[usb:002,005]

Where 002,005 is the (bus,device) pair. You can obtain this via

 $ gvfs-mount -li|grep "/dev/bus/usb"
    unix-device: '/dev/bus/usb/002/005'

once the device is plugged in.
Comment 11 Anthony Green 2008-06-11 17:20:04 EDT
(In reply to comment #10)
> (In reply to comment #9)
> > I get a similar result when I plug in my digital camera:
> 
> Does gphoto2(1) (e.g. with option -L, similar) work on the camera?

Yes.

> Does this
> crash happen every time or only intermittently? 

Intermittently.

> Any chance you obtain a stack
> trace? [1]

I can't get it to crash this way.  Any other ideas?

> 
> IIRC some shared gvfs code saw a few bug fixes so please also try this with the
> latest gvfs package in F9. Thanks.

I am using the latest.

# rpm -qa gvfs
gvfs-0.2.3-11.fc9.i386


> 
> [1] : The easiest way to do this is as follows
> 
>  $ gdb --args /usr/libexec/gvfsd-gphoto2 host=[usb:002,005]
> 
> Where 002,005 is the (bus,device) pair. You can obtain this via
> 
>  $ gvfs-mount -li|grep "/dev/bus/usb"
>     unix-device: '/dev/bus/usb/002/005'
> 
> once the device is plugged in.
> 

Comment 12 David Zeuthen 2008-06-11 18:52:16 EDT
> > Does this
> > crash happen every time or only intermittently? 
> 
> Intermittently.
> 
> > Any chance you obtain a stack
> > trace? [1]
> 
> I can't get it to crash this way.  

That's a useful data point.

> Any other ideas?

Not really. I think there's a general life-cycle management problem in the core
gvfs daemon.. maybe insofar that it spawns multiple mount daemons for the same
device. Not sure. I'll try investigating this upstream.

    David
Comment 13 Tomáš Bžatek 2008-06-12 05:49:18 EDT
There's a new gvfs version in dist-f9-updates-testing repository:
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-5197
But I doubt it will make any difference in this case.
Comment 14 Tom London 2009-05-19 17:15:09 EDT
This is very old, and I cannot reproduce this any longer on my rawhide system.

Close?
Comment 15 Tomáš Bžatek 2009-05-20 07:45:21 EDT
Closing for the time being, if the problem appears again, please reopen this bugreport. There was number of changes in gvfs since this issue was first reported.

Note You need to log in before you can comment on or make changes to this bug.