Bug 445045 - nm-vpn-properties crashes when changing connection name
Summary: nm-vpn-properties crashes when changing connection name
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-02 22:24 UTC by Jonathan Blandford
Modified: 2013-04-02 04:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 21:32:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Blandford 2008-05-02 22:24:02 UTC
Try to edit the Connection Name of a connection, and nm-vpn-properties crashes
upon hitting apply.

Comment 1 Warren Togami 2008-05-04 03:23:24 UTC
Please specify exactly which versions of NetworkManager and NetworkManager-vpnc
are installed.  Also be sure to test after a full reboot because the older
version of nm-system-settings could be screwing up the tests.

(I asked this Friday night, no details yet, and I can't reproduce this.)

Comment 2 Jonathan Blandford 2008-05-05 19:39:17 UTC
This is with NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386


Comment 3 Warren Togami 2008-05-05 21:13:48 UTC
I'm using NetworkManager-0.7.0-0.9.3.svn3623.fc9.x86_64 here.  It doesn't crash
here, but it does corrupt what is displayed in the VPN Connections menu. 
Closing that menu and opening it again it is displayed properly.

Comment 4 Dan Williams 2008-05-05 21:32:16 UTC
found and fixed in upstream applet svn r713


Note You need to log in before you can comment on or make changes to this bug.