Bug 445051 - network interfaces won't start after upgrade (e1000e more fussy)
network interfaces won't start after upgrade (e1000e more fussy)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-02 19:13 EDT by Andrew Bartlett
Modified: 2009-07-14 09:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 09:58:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Bartlett 2008-05-02 19:13:14 EDT
Description of problem:
After upgrade of system not using NetworkManager from Fedora 8 to rawhide (pre
Fedora 9), the network interface won't come up. 

Network driver is e1000e

Version-Release number of selected component (if applicable):
kernel-2.6.25-14.fc9.x86_64
initscripts-8.74-1.x86_64
dhclient-4.0.0-14.fc9.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. service network stop
2. service network start
3.
  
Actual results:
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:  
Determining IP information for eth0... failed; no link present.  Check cable?
                                                           [FAILED]

Log shows:
May  3 08:58:05 naomi kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready

Expected results:
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:  
Determining IP information for eth0... done.
                                                           [  OK  ]


Additional info:

ethtool shows a link at only 100Mbit (should be 1000Mbit) intermittently, other
times shows no link. 

Removing patch cable (cat 5, not 5e) via Belkin UPS solved the issue. 

It seems to me that the new driver is more fussy (and is probably saving me from
a life of pain later), but perhaps some release notes should indicate this?

Oddly, the install worked fine (upgrade over PXE booted network)
Comment 1 Bug Zapper 2008-05-14 06:33:55 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Christopher Tubbs 2009-03-22 03:09:57 EDT
Can't believe this bug's been around for almost a year as "high" priority and severity and nobody has touched it.

I'm having the same problems. It just started for me when I rebooted with 2.6.27.19-170.2.35.fc10.i686
Comment 3 Bug Zapper 2009-06-09 20:35:15 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2009-07-14 09:58:58 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.