Bug 445080 - named kills machine
named kills machine
Status: CLOSED DUPLICATE of bug 275091
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-03 07:24 EDT by Neal Becker
Modified: 2013-04-30 19:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 16:39:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2008-05-03 07:24:04 EDT
Description of problem:

I just tried a 2nd upgrade F8-> rawhide.

On reboot, it hung a long time on bringing up eth0, and failed.  This never
had a problem on F8.

06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B
PCI Express Gigabit Ethernet controller (rev 01)

When it went to start X, all I got was an 'X'.  And an apparantly dead
machine.

I rebooted into mode 3.  Ran top.  Nothing showed a significant load
average.  Quit top.  Now, no response from keyboard.

Rebooted into mode 1.  Looked at /var/log/messages.  Millions(?) of lines
from named.  chkconfig named off.  Rebooted again.  Now, running OK, but
still no eth0.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Tkac 2008-05-05 03:22:59 EDT
Named cannot break network device configuration.
- what kind of messages are in system log?
- are you using NetworkManager?
- are you sure this is not SELinux problem?

Thanks, Adam
Comment 2 Neal Becker 2008-05-05 05:52:32 EDT
Sorry for not being clear.  named did not break network config.  What happened
was:

1. eth0 was not brought up (for some other reason)
2. named went nuts, logging thousands of error messages, apparantly generating
so much load that machine was unusable.  (This diagnosis is a guess, but see
#3)
3. turning off named fixed the problem
4. selinux is/was disabled
Comment 3 Adam Tkac 2008-05-05 08:12:20 EDT
Would it be possible attach what messages were in log, please? I'm not able
track what happen without them.
Comment 4 Neal Becker 2008-05-05 08:31:00 EDT
They all look like this:

May  2 05:53:53 nbecker1 named[2410]: too many timeouts resolving
'localhost.md.hnsnet/AAAA' (in '.'?): disabling EDNS
May  2 05:53:54 nbecker1 named[2410]:last message repeated 3 times
May  2 05:53:54 nbecker1 named[2410]: too many timeouts resolving 'A.ROOT-
May  2 05:53:54 nbecker1 named[2410]: too many timeouts resolving
'localhost.md.hnsnet/AAAA' (in '.'?): disabling EDNS
May  2 05:53:59 nbecker1 named[2410]:last message repeated 3 times
May  2 05:53:54 nbecker1 named[2410]: too many timeouts resolving 'B.ROOT-
May  2 05:54:00 nbecker1 named[2410]:last message repeated 4 times
May  2 05:53:54 nbecker1 named[2410]: too many timeouts resolving 'C.ROOT-

Comment 5 Adam Tkac 2008-05-05 16:39:27 EDT
hm, I don't think those messages can kill machine. But bug about this "issue" is
already opened...

*** This bug has been marked as a duplicate of 275091 ***

Note You need to log in before you can comment on or make changes to this bug.