This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 445086 - viewing update detail unbound local error yumbackend
viewing update detail unbound local error yumbackend
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-05-03 08:10 EDT by David Timms
Modified: 2008-05-06 13:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 13:11:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
error dialog. (25.96 KB, image/png)
2008-05-03 08:10 EDT, David Timms
no flags Details
An untested patch that may fix the problem. (1.57 KB, patch)
2008-05-03 21:58 EDT, Luke Macken
no flags Details | Diff
A tested patch that fixes this issue (1.47 KB, patch)
2008-05-05 10:54 EDT, Luke Macken
no flags Details | Diff

  None (edit)
Description David Timms 2008-05-03 08:10:56 EDT
Description of problem:
During use of the view updates dialog, an error was produced

Version-Release number of selected component (if applicable):
PackageKit-0.1.12-8.20080425.fc9.i386
PackageKit-libs-0.1.12-8.20080425.fc9.i386

Reproduced with the python-sqlalchemy package listed.

Steps to Reproduce:
1. update icon says one update pending
2. click, show updates
3. review
  
Actual results:
The dialog expands, and opens up the lower part for description, and then
disappears, showing error dialog:
Update System
An internal system error has occurred
A problem that we were not expecting has occurred. Please report this bug with
the error description.
More details:
Error Type: <type 'exception.UnboundLocalError'>
...
line 1325, in _get_update_extras
  href = ref['href']

Expected results:
details of that package update.
This has worked for other updates.
Comment 1 David Timms 2008-05-03 08:10:56 EDT
Created attachment 304449 [details]
error dialog.
Comment 2 Jeremy Katz 2008-05-03 15:55:48 EDT
This looks like a real problem from a quick look at the code -- if there aren't
references, then ref is never getting set before its used
Comment 3 Luke Macken 2008-05-03 21:58:29 EDT
This bug was caused by improper tab->space conversion.  This problem does not
exist in the yum2 backend.
Comment 4 Luke Macken 2008-05-03 21:58:57 EDT
Created attachment 304472 [details]
An untested patch that may fix the problem.
Comment 5 Jeremy Katz 2008-05-04 13:25:04 EDT
You lost the 'if refs' check -- which may or may not matter.  Otherwise, it
looks sane from not knowing the code ;)
Comment 6 Luke Macken 2008-05-04 19:47:53 EDT
Yeah, the refs check shouldn't matter -- the
yum.update_md.UpdateNotice.references defaults to an empty list.
Comment 7 Matthias Clasen 2008-05-05 09:45:58 EDT
Robin, Richard, can we get this fix built ?
Comment 8 Luke Macken 2008-05-05 10:54:05 EDT
Ok, so apparently the refs check *is* necessary.  Attaching a tested patch that
seems to do the trick.
Comment 9 Luke Macken 2008-05-05 10:54:34 EDT
Created attachment 304527 [details]
A tested patch that fixes this issue
Comment 10 Luke Macken 2008-05-05 10:59:27 EDT
Fixed in 34368f7fa13b3ac7d2a16d570d450a027e66dd75
Comment 11 Jeremy Katz 2008-05-05 11:45:31 EDT
Need a build in dist-f9-updates-candidate and mail to rel-eng@fedoraproject.org
with the nvr for tagging please :)
Comment 12 Richard Hughes 2008-05-05 12:02:41 EDT
Is this okay to mark as a release blocker? Cheers for fixing this guys. I'll do
a snapshot release tmw morning and get this into F9.
Comment 14 Bill Nottingham 2008-05-05 13:24:09 EDT
Tagged for the tree.

Note You need to log in before you can comment on or make changes to this bug.