Bug 445096 - apt Autoupdates w/o user permission
apt Autoupdates w/o user permission
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: apt (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-03 13:24 EDT by Suren Karapetyan
Modified: 2009-01-14 22:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 22:11:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suren Karapetyan 2008-05-03 13:24:44 EDT
Description of problem:
The default install of apt adds a script in cron.daily to run apt-get update
every night.
There is CHECK_ONLY option in /etc/sysconfig/apt which (defaults to no) if set
to yes only checks for updates. Note that it's the default behaviour of
yum-updatesd (it doesn't update without asking you)

Version-Release number of selected component (if applicable):
Well for me it's apt-0.5.15lorg3.94-3

How reproducible:
Nicely :)

Steps to Reproduce:
1.yum install apt
2.go to sleep
3.enjoy Your fully upgraded system (read: have fun uninstalling mesa*, half of
xorg, and all the kernel modules, cause you've been using rawhide and didn't
update the badly broken parts. Switch back to "fedora-stable", install mesa*,
xserver, rhxpl, ... Again switch back to rawhide and don't forget to check
/etc/sysconfig/apt to switch the line from "CHECK_ONLY=no" to "CHECK_ONLY=yes")
  
Actual results:
Loads of fun doing degrading :D

Expected results:
Synaptic
Comment 1 Kevin Kofler 2008-05-04 16:48:49 EDT
The real bug there is that the apt service is running by default, it's supposed 
to be disabled by default and this has always been the case. CHECK_ONLY is only 
relevant if the apt service is actually enabled.
Comment 2 Kevin Kofler 2008-05-04 16:49:21 EDT
(Maybe a regression caused by the switch from SysVInit to Upstart?)
Comment 3 Suren Karapetyan 2008-05-04 17:28:30 EDT
(In reply to comment #1)
> The real bug there is that the apt service is running by default, it's
supposed 
> to be disabled by default and this has always been the case. CHECK_ONLY is
only 
> relevant if the apt service is actually enabled.

Well.. I mostly agree with You: apt service should be disabled.
But even if apt is disabled and a user enables it himself, he/she will
probably expect it to behave just like yum-updatesd (i.e. only update the
package list - not the packages).
So IMO the service should be disabled and CHECK_ONLY should be yes.

BTW: /etc/init.d/apt is a really funny script to read :)
It's the only thing I've seen which uses touch/rm to control a cron job and
emulate a service.
I don't say I don't like it (well.. opposite: I do LOVE it) but it really
looks like a hack :D
Comment 4 Bug Zapper 2008-05-14 06:36:00 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Suren Karapetyan 2008-06-21 06:12:56 EDT
Ping?
Anybody out there?

Come on guys... this is EASY.
I don't even think there is need for maintainer's permission to do this.
Comment 6 Fedora Update System 2009-01-07 03:05:14 EST
apt-0.5.15lorg3.95-0.git416.3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/apt-0.5.15lorg3.95-0.git416.3.fc10
Comment 7 Suren Karapetyan 2009-01-07 07:56:18 EST
apt-0.5.15lorg3.95-0.git416 (at least partly) fixes this, but it still isn't the expected behaviour.
In the old times when we had yum-updatesd it was on by default but it only downloaded package lists (to be able to tell You if there is an update) instead of autoupdating.
To get the same result with apt the "CHECK_ONLY=no" should be changed to "CHECK_ONLY=yes" in /etc/sysconfig/apt
Comment 8 Fedora Update System 2009-01-07 16:52:28 EST
apt-0.5.15lorg3.95-0.git416.3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update apt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0304
Comment 9 Fedora Update System 2009-01-14 22:10:48 EST
apt-0.5.15lorg3.95-0.git416.3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.