Bug 445113 - setup-ds-admin.pl Cannot find Setup.pm in @INC on Fedora 8 x86_64
setup-ds-admin.pl Cannot find Setup.pm in @INC on Fedora 8 x86_64
Status: CLOSED NOTABUG
Product: 389
Classification: Community
Component: Install/Uninstall (Show other bugs)
1.1.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Nathan Kinder
Orla Hegarty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-03 19:14 EDT by Ryan
Modified: 2008-08-11 19:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 19:32:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan 2008-05-03 19:14:01 EDT
Description of problem: On Fedora 8 x86_64, running setup-ds-admin results in
the error "Cannot find Setup.pm in @INC".  I believe this is due to the fact
that setup-ds-admin.pl has what may be an error on line 20 and 'use lib
qw(/usr/lib/dirsrv/perl);' should be 'use lib qw(/usr/lib64/dirsrv/perl);' 
Making the previously mentioned change allows the script to run successfully
until the admin server is started.  Something seems to incorrectly set the admin
server's config files to use /usr/lib instead of /usr/lib64.  Manually changing
all instances of /usr/lib to /usr/lib64 in all files under
/etc/dirsrv/admin-serv allows the dirsrv-admin service to successfully start.


Version-Release number of selected component (if applicable):fedora-ds 1.1.1-2


How reproducible:Easy


Steps to Reproduce:
1. yum install fedora-ds
2. Run setup-ds-admin.pl
  
Actual results:


Expected results:


Additional info:
Comment 1 Nathan Kinder 2008-05-05 12:35:23 EDT
It sounds like you have the i386 fedora-ds-admin package installed instead of
the x86_64 version.  Please check which architecture your fedora-ds-admin
pacakge is with this command:

    rpm -q --qf "%{NAME}.%{ARCH}\n" fedora-ds-admin
Comment 2 Ryan 2008-05-05 19:32:37 EDT
Thanks!  That seems to be it.  I somehow have both installed.  It is working
though after the changes I made.  Might be worthwhile to go back and make sure I
am running the 64-bit version.  Thanks for the work you guys do.  I have been
waiting quite a while for the new admin and it seems well worth the wait.  Even
with the little mess up I did it was much easier to install than the old version.
Comment 3 Chandrasekar Kannan 2008-08-11 19:56:21 EDT
Bug already CLOSED. setting screened+ flag

Note You need to log in before you can comment on or make changes to this bug.