Bug 445118 - RFE: have gdm (gdm-session-worker?) save ~/.xsession-errors in ~/.xsession-errors.old
RFE: have gdm (gdm-session-worker?) save ~/.xsession-errors in ~/.xsession-er...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-03 20:34 EDT by Tom London
Modified: 2015-01-14 18:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-04 11:12:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-05-03 20:34:11 EDT
Description of problem:
It would ease debugging session related issues if gdm were to save the current
~/.xsession-errors (for example, as ~/.xsession-errors.old).  This is parallel
to what Xserver does with /var/log/Xorg.0.log.

That way, you could log back in normally and still see "what happened". 
Otherwise, you have to remember to boot up in runlevel 3, or Cntl-Alt-F1 etc.

I tried adding 'mv -f "$errfile" "$errfile.old"' to /etc/X11/xinit/Xsession to
no avail, so I'm guessing that this is now handled in a gdm-related command
(gdm-session-worker has the string......).


Version-Release number of selected component (if applicable):
gdm-2.22.0-1.fc9.i386

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-05-03 21:15:59 EDT
I've located the code '_open_session_log()' in gdm-session-worker.c, and that
looks like the relevant piece of code.

If that is correct (and this is a useful change), I can try making a patch for
this.....
Comment 2 Ray Strode [halfline] 2008-05-04 11:12:38 EDT
Sure, I think a patch like that probably makes sense.  Would you mind filing the
patch upstream though?
Comment 3 Tom London 2008-05-05 12:41:52 EDT
No problem.

I'm downloading the current source so I can post a "current" patch.

I'll reference this BZ on the upstream post.
Comment 4 Tom London 2008-05-05 13:39:21 EDT
Upstream RFE/patch filed here: http://bugzilla.gnome.org/show_bug.cgi?id=531587

Note You need to log in before you can comment on or make changes to this bug.