Bug 445119 - Regression: acccess to window shares should use kerberos before prompting for credentials
Regression: acccess to window shares should use kerberos before prompting for...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-03 20:44 EDT by Andrew Duggan
Modified: 2015-03-03 17:32 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.24 (F10)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 21:13:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 524498 None None None Never

  None (edit)
Description Andrew Duggan 2008-05-03 20:44:56 EDT
Description of problem:
smb protocol from connect to server or gtk-bookmarks always prompt for
credentials (unless saved) even when user is holding a valid krb5 ticket that
could be used for authentication.

Version-Release number of selected component (if applicable):
2.22.2-7.fc9

How reproducible:
Always

Steps to Reproduce:
1. kinit user@DOMAIN
2. Open a nautilus window and select File Menu->"Connect to Server..."
3. Enter type of Windows Share, enter server and share names
  
Actual results:
Dialog prompts for credentials, one has to remove the prefilled username and
workgroup name (or select cancel) to get the login to use the kerberos ticket
from step 1

Expected results:
Login proceeds without dialog box.

Additional info:
This is a regression from Fedora 8.
Comment 1 Tomáš Bžatek 2008-05-05 07:37:32 EDT
gvfs-smb backend should use active kerberos tickets automatically and should not
ask for passwords.

Can you please try opening the URI (syntax: smb://username@server/share)
directly from nautilus, bypassing the Connect to Server dialog? (File -> Open
Location... or press Ctrl+L)
Comment 2 Andrew Duggan 2008-05-05 10:11:21 EDT
Just tried that syntax and it still presents the authentication dialog.  One
thing I didn't make clear before is that my fedora login username != domain
username. Plus the machine domain name != windows domain either.  However I did
just create another local account where the username matches the windows
username and I still get prompted either way (connect to server or directly
opening a location with smb://username@server/share.

System was an upgrade from F8 to F9-Beta then updates to present.

Thanks.
Comment 3 Tomáš Bžatek 2008-05-05 16:11:51 EDT
Linking to upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=524498
Comment 4 Bug Zapper 2008-05-14 06:36:50 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2009-06-09 20:36:32 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Andrew Duggan 2009-06-09 21:13:21 EDT
Was fixed in F10.

Note You need to log in before you can comment on or make changes to this bug.