Bug 445124 - B43 driver does not work
Summary: B43 driver does not work
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-04 03:36 UTC by Benjamin Kreuter
Modified: 2008-08-19 18:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-19 18:47:13 UTC
Type: ---


Attachments (Terms of Use)

Description Benjamin Kreuter 2008-05-04 03:36:42 UTC
Description of problem:
The b43 driver fails to work properly with a BCM4311 wireless card in a Dell 
D620 laptop.


Version-Release number of selected component (if applicable):
kernel-2.6.24.5-85


How reproducible:
Always

Steps to Reproduce:
1. Load b43 module
2. Connect to wireless network with NetworkManager
3. Ping default gateway (or other well known device)
  
Actual results:
No network traffic.

Expected results:
Should transmit and receive packets

Additional info:
ifconfig reports packets being transmitted and received, but there is no 
actual connectivity.

Comment 1 John W. Linville 2008-05-05 16:23:07 UTC
Please attach the output of 'lspci -n' the contents 
of "/sys/bus/ssb/devices/ssb0:0/uevent".

Unless this is a new device, the 4311 has been well supported for some time.  
Are you sure that you don't simply have the rfkill switch enabled?  If this 
was an unknown devices then I don't think ifconfig would show a device at all.

Comment 2 Benjamin Kreuter 2008-05-05 16:34:25 UTC
lspci -n:
00:00.0 0600: 8086:27a0 (rev 03)
00:02.0 0300: 8086:27a2 (rev 03)
00:02.1 0380: 8086:27a6 (rev 03)
00:1b.0 0403: 8086:27d8 (rev 01)
00:1c.0 0604: 8086:27d0 (rev 01)
00:1c.1 0604: 8086:27d2 (rev 01)
00:1c.2 0604: 8086:27d4 (rev 01)
00:1d.0 0c03: 8086:27c8 (rev 01)
00:1d.1 0c03: 8086:27c9 (rev 01)
00:1d.2 0c03: 8086:27ca (rev 01)
00:1d.3 0c03: 8086:27cb (rev 01)
00:1d.7 0c03: 8086:27cc (rev 01)
00:1e.0 0604: 8086:2448 (rev e1)
00:1f.0 0601: 8086:27b9 (rev 01)
00:1f.2 0101: 8086:27c4 (rev 01)
00:1f.3 0c05: 8086:27da (rev 01)
03:01.0 0607: 1217:6972 (rev 40)
09:00.0 0200: 14e4:1600 (rev 02)
0c:00.0 0280: 14e4:4311 (rev 01)

DRIVER=b43
PHYSDEVBUS=ssb
PHYSDEVDRIVER=b43
MODALIAS=ssb:v4243id0812rev0A

The rfkill switch is definitely not enabled.  The b43 driver only recently 
began working correctly, starting with the 2.6.24 kernel, and this break 
appears to be a regression of some sort.  In previous 2.6.24 kernels, the card 
worked, although occasionally all network traffic would stop and the b43 
module would have to be unloaded and loaded to get things working again.  The 
card does work correctly with ndiswrapper, but I would rather use free 
drivers.

Comment 3 John W. Linville 2008-07-08 19:57:19 UTC
Are you still experiencing this issue with recent kernels?

Comment 4 John W. Linville 2008-08-19 18:47:13 UTC
Closed due to lack of response...


Note You need to log in before you can comment on or make changes to this bug.