Bug 445130 - wbxml2-0.9.2-namespaces.patch breaks DRMREL
wbxml2-0.9.2-namespaces.patch breaks DRMREL
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wbxml2 (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-04 06:36 EDT by Pau Aliagas
Modified: 2008-09-10 03:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-05 08:18:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
drmrel example file (922 bytes, text/plain)
2008-05-04 06:36 EDT, Pau Aliagas
no flags Details
patch attempt to support namespaces in drmrel (2.69 KB, text/x-patch)
2008-05-04 06:38 EDT, Pau Aliagas
no flags Details

  None (edit)
Description Pau Aliagas 2008-05-04 06:36:28 EDT
Description of problem:

The latest patch applied to wbxml2 (wbxml2-0.9.2-namespaces.patch) breaks the
support for DRMREL. This is due to the change in namespaces managment which
maybe is ok for SyncML, but hasn't added the needed changes for DRMREL.

Version-Release number of selected component (if applicable):
Latest

How reproducible:
Try to encode the attached valid drmrel file like this:
xml2wbxml -i pau.dr -o pau.wbxml
Without the patch it works, with the patch it fails.

Steps to Reproduce:
1. xml2wbxml -i pau.dr -o pau.wbxml
2.
3.
  
Actual results:
xml2wbxml failed: Unknown Error Code

Expected results:
xml2wbxml succeded

Additional info:

I've tried to create a patch to add the namespace support for DRMREL but it does
not work. I attach it for your review and, if possible, to fix it and add it.
I've contacted the original author, Aymerick Jéhanne, to include the patches in
the distribution and to fix drmrel too.
Comment 1 Pau Aliagas 2008-05-04 06:36:28 EDT
Created attachment 304484 [details]
drmrel example file
Comment 2 Pau Aliagas 2008-05-04 06:38:14 EDT
Created attachment 304487 [details]
patch attempt to support namespaces in drmrel
Comment 3 Pau Aliagas 2008-05-12 18:05:22 EDT
any news?
Comment 4 Laurent Rineau 2008-05-13 02:46:29 EDT
Andreas, I assigned that bug to you, because you introduced those patches. 
Tell us if you do not have time, currently, to handle that.
Comment 5 Andreas Bierfert 2008-05-13 07:18:33 EDT
I am currently investigating what the proper way to resolve this bug is. I will
try to get this resolved asap but I would like a cleaner solution better then a
quick hack. I will see what the synce folks say to this as well. If you hear
from the author of wbxml2 please forward the mail.
Comment 6 Pau Aliagas 2008-05-13 07:38:03 EDT
The quick hack would have been to remove the culprit patch. I tried to do
something similar for DRMREL, the language broken by it, but I diod not succedd,
I did not have more time to invest, in my copy I had to remove the patch, I was
using the libary and it stopped working. In fact I was the original packager and
helped Aymerick with all the makefiles, etc.

I've tried to contact him but he must be unavailable for some time, we happen to
be friends. I sent him all the patches for review.

If you contact the synce folks, I had also to fix pywbxml whcih did not work as
published, I'll be more than glad to send them the patch to fix it.

I hope we can solve it soon, I'll be glad to help.
Comment 7 Fedora Update System 2008-06-18 05:59:11 EDT
wbxml2-0.9.2-13.fc8 has been submitted as an update for Fedora 8
Comment 8 Fedora Update System 2008-06-18 05:59:49 EDT
wbxml2-0.9.2-14.fc9 has been submitted as an update for Fedora 9
Comment 9 Pau Aliagas 2008-06-19 19:15:12 EDT
As a comment, it would be nice to have a small explanation of the resolution
here, I'll predicate with the example:
Verbatim from rawhide wbxml2-0.9.2-14.fc10.src.rpm:

* Wed Jun 18 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 0.9.2-14
- drop synce patches (not needed anymore, fixes #445130)

And copied from the former rpm:
#synce patches
Patch101: wbxml2-0.9.2-anonymous-support-and-misc-fixes.patch
Patch102: wbxml2-0.9.2-namespaces.patch

The second one it the one  I removed from my copy to fix it.

BTW, pywbxml is still broken, default params have been overriden for bad.
Comment 10 Fedora Update System 2008-06-20 15:04:32 EDT
wbxml2-0.9.2-14.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wbxml2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5449
Comment 11 Pau Aliagas 2008-06-23 03:23:37 EDT
I've tested the fix and it works. For me the bug is closed. I've reported it to
the fedora updates link provided above too.
Thanks
Comment 12 Fedora Update System 2008-09-05 08:18:15 EDT
wbxml2-0.9.2-14.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-09-05 08:18:22 EDT
wbxml2-0.9.2-13.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2008-09-10 02:49:27 EDT
wbxml2-0.9.2-14.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2008-09-10 03:08:14 EDT
wbxml2-0.9.2-13.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.