Bug 445138 - fixup distribution of auto-generated mime-data
fixup distribution of auto-generated mime-data
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: monodevelop (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-04 11:19 EDT by Christian Krause
Modified: 2008-11-19 09:34 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-19 09:34:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch which fixes the distribution of the auto-generated mime data (1.52 KB, patch)
2008-05-04 11:19 EDT, Christian Krause
no flags Details | Diff

  None (edit)
Description Christian Krause 2008-05-04 11:19:35 EDT
The monodevelop rpm packages contains a lot of auto-generated mime data. This
causes a failure of the integrity check:

rpm -V monodevelop
...
S.5....T   /usr/share/mime/application/x-soap-remoting.xml
S.5....T   /usr/share/mime/application/x-web-config.xml
S.5....T   /usr/share/mime/application/x-wsdl.xml
S.5....T   /usr/share/mime/globs
S.5....T   /usr/share/mime/magic
S.5....T   /usr/share/mime/mime.cache
S.5....T   /usr/share/mime/text/x-csharp.xml
S.5....T   /usr/share/mime/text/x-js.xml
S.5....T   /usr/share/mime/text/x-msil.xml
...

These files are auto-generated during the installation of the package via
"update-mime-database" and they should not be distributed within the package itself.

I've attached a small patch to the spec file which fixes the problem (similar to
control-center.spec).
Comment 1 Christian Krause 2008-05-04 11:19:35 EDT
Created attachment 304494 [details]
patch which fixes the distribution of the auto-generated mime data
Comment 2 Christian Krause 2008-05-14 16:43:03 EDT
This Bug was closed as fixed in rawhide, but I haven't seen a new package yet...
:-( Did (or will) the patch make it into F9? 
Comment 3 Paul F. Johnson 2008-05-14 17:18:18 EDT
It should be in rawhide. I'm going to try and unify all of my mono stuff for F9
(and possibly F8) for the end of June.
Comment 4 Christian Krause 2008-05-14 18:35:59 EDT
Hi Paul,

(In reply to comment #3)
> It should be in rawhide. 

I'm sorry to bother you again, but I'm afraid something went wrong. :-( There is
neither a new package out in rawhide nor got
rpms/monodevelop/devel/monodevelop.spec in cvs updated.

> I'm going to try and unify all of my mono stuff for F9
> (and possibly F8) for the end of June.

This would be great! Thank you very much in advance!

Best regards,
Christian
Comment 5 Christian Krause 2008-06-14 15:16:14 EDT
Unfortunately the fix has not landed yet in the most recent RAWHIDE package, so
I'm going to re-open the bug. ;-) 
Comment 6 Paul F. Johnson 2008-09-17 20:00:59 EDT
According to the change log, version 1.0-6 had the mime data removed (this is the version which will hit F9 when gnome-desktop-sharp hits it)
Comment 7 Christian Krause 2008-11-19 09:33:33 EST
The problem is fixed in Rawhide and since there is no urgency to fix it in F9 as well, I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.