Bug 445167 - DVD Copy: not enough space in temporary folder - LIE!!!
DVD Copy: not enough space in temporary folder - LIE!!!
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-04 23:26 EDT by The Source
Modified: 2014-01-12 19:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 09:14:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description The Source 2008-05-04 23:26:38 EDT
Description of problem:
When I try to copy DVD to iso file to one of my partitions (make image only, NOT
into /tmp, but into directory of my choice), k3b says not enough free space in
temporary directory. I have more that enough free space in directory I chose and
even in /tmp. So it is obviously a bug.

Version-Release number of selected component (if applicable):
k3b-1.0.4-5.fc8

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 The Source 2008-05-04 23:28:20 EDT
Haha. K3b shows that I have 0 bytes free in that directory. But that's a lie.
Comment 2 The Source 2008-05-04 23:31:42 EDT
Ok, seems that k3b detects free space 0 on all ntfs volumes. And how that can be
I wonder? Does it use something else instead of asking the system? Nautilus
shows free space properly. And I can write there without any problems.
Comment 3 Roman Rakus 2008-05-05 10:23:08 EDT
k3b uses system calls for this stuff:
bool K3b::kbFreeOnFs( const QString& path, unsigned long& size, unsigned long&
avail )
{
  struct statvfs fs;
  if( ::statvfs( QFile::encodeName(path), &fs ) == 0 ) {
    unsigned long kBfak = fs.f_frsize/1024;

    size = fs.f_blocks*kBfak;
    avail = fs.f_bavail*kBfak;

    return true;
  }
  else
    return false;
}

Unfortunately I can't reproduce this bug at this moment. Nevertheless, I don't
think, it's good idea to write to ntfs volume. Better should be using some FAT...
Comment 4 The Source 2008-05-05 11:54:37 EDT
Note, that this bug was not present in earlier versions of k3b. For example in
versions below 1.0 I was saving images to ntfs without any problems.
Comment 5 Roman Rakus 2008-05-06 07:38:53 EDT
Now I have tried to create image of DVD, writing to NTFS and everything was
successful. Can you tell me what version of ntfs-3g, ntfsprogs and glibc do you
have? Check it by this cmd:
    rpm -qa | egrep "ntfsprogs|ntfs-3g|glibc"
Comment 6 The Source 2008-05-06 07:51:00 EDT
ntfs-3g-1.1120-1.fc8
glibc-2.7-2
glibc-devel-2.7-2
ntfsprogs-1.13.1-8.fc8
glibc-common-2.7-2
glibc-headers-2.7-2
Comment 7 Roman Rakus 2008-05-06 09:02:17 EDT
Hmm... same as me. And how you are mounting your ntfs? And what says mount?
Comment 8 The Source 2008-05-16 05:54:14 EDT
I mount through /etc/fstab. The line is the following:
/dev/sdb1 /mnt/d ntfs-3g defaults,force,umask=0000,exec,nls=utf8

I checked partition with chkdsk in Vista. Everything was fine.
Comment 9 Roman Rakus 2008-05-19 06:23:32 EDT
Try to change line to:
/dev/sdb1 /mnt/d ntfs-3g rw  0 0
This works for me
Comment 10 The Source 2008-05-19 09:51:10 EDT
Tried it but no luck. Still shows 0 free space on both Fedora 8 64 bit (home PC)
and Fedora 9 32bit (work PC).

Note You need to log in before you can comment on or make changes to this bug.