Bug 445169 - taskjuggler has suspicious obsoletes
taskjuggler has suspicious obsoletes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: taskjuggler (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-05 00:03 EDT by Bruno Wolff III
Modified: 2008-07-26 02:09 EDT (History)
0 users

See Also:
Fixed In Version: 2.4.0-8.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 18:12:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2008-05-05 00:03:18 EDT
Description of problem:
When I tried to install taskjuggler I got taskjuggler-libs installed instead
because it obsoletes taskjuggler. However since both are in the repository with
the same version, this seems very unlikely to be correct.

Version-Release number of selected component (if applicable):
2.4.0-7.fc9

How reproducible:
100%

Steps to Reproduce:
1. yum install taskjuggler -y
2.
3.
  
Actual results:
Package taskjuggler is obsoleted by taskjuggler-libs, trying to install
taskjuggler-libs-2.4.0-7.fc9.i386 instead


Expected results:
That taskjuggler (and perhaps taskjuggler-libs as well) would be installed.

Additional info:
Comment 1 Bruno Wolff III 2008-05-05 00:07:03 EDT
As a work around I was able to install taskjuggler with rpm.
Comment 2 Ondrej Vasik 2008-05-13 10:22:33 EDT
Thanks for report... really ugly typo. Obsoletes: %{name} < %{version}-{%release}
instead of Obsoletes: %{name} < %{version}-%{release} caused the troubles. Build
as taskjuggler-2.4.0-8.fc9 and taskjuggler-2.4.1-0.2.beta2.fc10 , sorry for
troubles, closing RAWHIDE
Comment 3 Fedora Update System 2008-05-13 17:01:08 EDT
taskjuggler-2.4.0-8.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-05-14 18:12:04 EDT
taskjuggler-2.4.0-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Bruno Wolff III 2008-05-15 00:45:11 EDT
I tried it out and it installs properly now. Thanks.
Comment 6 Fedora Update System 2008-07-26 02:09:26 EDT
taskjuggler-2.4.0-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.