Bug 44517 - Can't generate system identifier
Can't generate system identifier
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: docbook-utils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-13 18:50 EDT by Stephen Rasku
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-14 14:34:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Rasku 2001-06-13 18:50:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; SunOS 5.7 sun4u)

Description of problem:
The following document:

<!DOCTYPE article PUBLIC "-//OASIS//DTD DocBook V3.1//EN">
<article class="TechReport">
<title>Title</title>
<artheader>
<author><firstname>Stephen</firstname><surname>Rasku</surname></author>
</artheader>
<sect1><title>Section Title</title>
<para>Paragraph</para>
</sect1>
</article>

Generates the following errors from db2ps:

[stephen@kiev devs/docs] 608 $ db2ps test.sgml 
Using catalogs: /etc/sgml/sgml-docbook-3.1.cat
Using stylesheet: /usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl#print
Working on: /tgi/data/stephen/enroute/msgr/devs/docs/test.sgml
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:1:73:W: cannot
generate system identifier for public text "-//James Clark//DTD DSSSL Style
Sheet//EN"
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:9:96:W: cannot
generate system identifier for public text "-//Norman Walsh//DOCUMENT
DocBook Print Stylesheet//EN"
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:11:0:E: reference
to entity "STYLE-SHEET" for which no system identifier could be generated
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:1:0: entity was
defined here
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:11:0:E: DTD did
not contain element declaration for document type name
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:9:0:E: notation
"DSSSL" for entity "docbook.dsl" undefined
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:30:12:E: element
"STYLE-SHEET" undefined
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:33:24:E: there is
no attribute "ID"
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:33:36:E: there is
no attribute "USE"
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:33:45:E: element
"STYLE-SPECIFICATION" undefined
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:34:25:E: element
"STYLE-SPECIFICATION-BODY" undefined
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:540:44:E: element
"STYLE-SPECIFICATION" undefined
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:541:25:E: element
"STYLE-SPECIFICATION-BODY" undefined
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:1115:27:E: there
is no attribute "ID"
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:1115:46:E: there
is no attribute "DOCUMENT"
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:1115:59:E: element
"EXTERNAL-SPECIFICATION" undefined
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:1117:13:E: end tag
for "EXTERNAL-SPECIFICATION" omitted, but OMITTAG NO was specified
jade:/usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl:1115:0: start tag
was here
jade:E: specification document does not have the DSSSL architecture as a
base architecture
jade:E: no style-specification or external-specification with ID "PRINT"

.
.
.


How reproducible:
Always
Comment 1 Tim Waugh 2001-06-14 08:44:47 EDT
Works for me.  Do you have docbook-dtd31-sgml installed?  How did you install 
Red Hat Linux 7.1: was it an upgrade, or a clean installation?  If an upgrade, 
what from?
Comment 2 Stephen Rasku 2001-06-14 11:47:25 EDT
docbook-dtd31-sgml-1.0-10 is installed.  I upgraded from a 7.1 beta.  Wolverine,
I believe.
Comment 3 Tim Waugh 2001-06-14 14:34:19 EDT
Right, that's why.  Uninstall openjade, and all of the packages that depend on 
it, 'rm -rf /etc/sgml', and then re-install them.
Comment 4 Stephen Rasku 2001-06-14 15:30:16 EDT
OK, that works.  Closing...
Comment 5 Stephen Rasku 2001-06-16 12:50:47 EDT
Testing, please ignore...

Note You need to log in before you can comment on or make changes to this bug.