Bug 445187 - Xorg Crashes After Eclipse Loads
Xorg Crashes After Eclipse Loads
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
All Linux
low Severity urgent
: ---
: ---
Assigned To: Dave Airlie
Depends On:
  Show dependency treegraph
Reported: 2008-05-05 07:06 EDT by Chris Spencer
Modified: 2009-01-09 02:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-09 02:48:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg log. (82.81 KB, text/plain)
2008-05-05 17:06 EDT, Chris Spencer
no flags Details
Xorg.conf. (2.29 KB, text/plain)
2008-05-05 17:07 EDT, Chris Spencer
no flags Details

  None (edit)
Description Chris Spencer 2008-05-05 07:06:00 EDT
Description of problem:
Xorg becomes unresponsive after starting Eclipse. It doesn't even respond to
ctrl+alt+backspace or ctrl+alt+delete.

Version-Release number of selected component (if applicable):
Eclipse-platform 3.3.0-31
Xorg-x11-server 1.3.0

How reproducible:

Steps to Reproduce:
1.Open Eclipse.

Additional info:
I have an ATI Radeon card, and I'm using the open source driver.
Comment 1 Matěj Cepl 2008-05-05 11:50:02 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Chris Spencer 2008-05-05 17:06:39 EDT
Created attachment 304559 [details]
Xorg log.
Comment 3 Chris Spencer 2008-05-05 17:07:08 EDT
Created attachment 304560 [details]
Comment 4 Chris Spencer 2008-05-05 17:17:57 EDT
Hi Matej,

Thanks for the quick reply. I tried letting X autodetect my setup, but I have
dual monitors with spanning desktops, and it doesn't configure them properly.
The problem with Eclipse only happens when it launches Eclipse in my second
monitor. When I changed the screens around in my xorg, so that the second screen
was shown on my first monitor, X does not crash. My video card has a VGA and DVI
output. My first screen uses DVI, while the second uses VGA.
Comment 5 Matěj Cepl 2008-05-06 08:47:34 EDT
OK, passing to engineers. I have to check whether we have not have some
duplicates of this. I didn't know that this is dual monitor.
Comment 6 Matěj Cepl 2008-05-06 08:53:51 EDT
Meanwhile if you have more than one computer connected via LAN, you can try to
debug it following the advice on
http://www.x.org/wiki/Development/Documentation/ServerDebugging. The problem I
have here is that there is no weird things happening in /var/log/Xorg.0.log,
because apparently X didn't really crashed just got stuck somewhere. Of course,
from your point of view, it doesn't matter whether Xorg crashed or got frozen,
but we don't have much to stand on.
Comment 7 Dave Airlie 2008-05-06 20:49:17 EDT
well you're xorg.conf is the problem really.

you might want to try turning EXA on for both heads, or turning XAA on for both
heads, I'm just building an xf86-video-ati-6.8.0-13 driver for F9 updates that
fixes a lot of EXA and zaphod dual-head problems.

However you're over complicated xorg.conf is probably what is causing eclipse to
crash. for one AccelDFS can't work with zaphod dual-head neither can any DRI/3D

you may want to investigate normal xrandr 1.2 multi-monitor support.
Comment 8 Matěj Cepl 2008-05-07 14:23:17 EDT
Try start without xorg.conf and then use gnome-display-properties

Does it work?
Comment 9 Chris Spencer 2008-05-07 19:58:02 EDT
I originally had both using EXA or both using XAA, but one of the screens was so
slow at rendering as to be unusable. I had looked at xrandr, but I couldn't find
any good guides on setting it up. I'll retry those this weekend.

Unfortunately, gnome-display-properties is what got me into this mess in the
first place. It doesn't correctly configure my dual head display at all. When I
first tried in back in January, after a fresh F8 install, it's configuration
made X crash on startup. Now it just makes my second display mirror the first.
The "spanning desktop" option is what usually seems to break it.
Comment 10 Dave Airlie 2008-05-07 20:09:48 EDT
no you used system-config-display, F9 now ships a gnome randr app.

you only probably need one line in xorg.conf to set a virtual screen size.
Comment 11 Bug Zapper 2008-11-26 05:38:25 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 12 Bug Zapper 2009-01-09 02:48:29 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.