Bug 445193 - elographics driver fails to initialize
elographics driver fails to initialize
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-elographics (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-05 08:07 EDT by Uwe Kubosch
Modified: 2008-11-06 21:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 21:50:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log when the probe fails (42.21 KB, text/plain)
2008-05-06 05:46 EDT, Uwe Kubosch
no flags Details
X server log when the probe succeeds (235.92 KB, text/plain)
2008-05-06 05:47 EDT, Uwe Kubosch
no flags Details
Naive patch to allow driver to start up without response to hardware probes. (1.34 KB, application/octet-stream)
2008-10-13 18:52 EDT, Uwe Kubosch
no flags Details
Add suppport for "Model" option, and support Sunit dSeries model (8.23 KB, patch)
2008-10-13 20:02 EDT, Peter Hutterer
no flags Details | Diff

  None (edit)
Description Uwe Kubosch 2008-05-05 08:07:03 EDT
Description of problem:

We have a project using Sunit dSeries vehicle computers
http://sunit.fi/
Fedora installs and runs fine.  Excellent work, guys!
The Sunit dSeries device has a Elo AccuTouch compatible touch screen attached to
/dev/ttyS1 and it works with the xorg-x11-drv-elographics driver.

The only problem is that the driver insists on probing the device at startup,
insisting on a response that never comes, and the shuts down.

A fix for this is adding an option "AllowNoCntl" that would allow the driver to
start up even if there is no response to the identification probe.  This has
already been implemented for XFree86, I think.

We have a workaround:  If we operate the touch screen during X startup, the
device is successfully identified (probably due to random coordinates sent) as 

(--) Elographics touchscreen is a AccuTouch, connected through a serial link.
(--) The controller is a model E271-2200, firmware revision 2.0.



Version-Release number of selected component (if applicable):

1.1.0-4.fc8 

How reproducible:

Steps to Reproduce:
1. Install Fedora 8 on Sunit d12 Vehicle Computer.
2. Add touch screen device to xorg.conf

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Touchscreen"
EndSection

Section "InputDevice"
        Identifier "Touchscreen"
        Driver "elographics"
        Option "Device" "/dev/ttyS1"
        Option "Name" "ELO Touchscreen"
        Option "AlwaysCore" "On"
        Option "ScreenNo" "0"
        Option "MinX" "341"
        Option "MaxX" "3738"
        Option "MinY" "471"
        Option "MaxY" "3554"
        Option "UntouchDelay" "3"
        Option "ReportDelay" "1"
        Option "debuglevel" "5"
EndSection

3. Restart GDM
  
Actual results:

The ELO Touchscreen device fails to initialize with the following error message
in /var/log/Xorg.0.log:

Unable to ask Elographics touchscreen identification

If the touch screen is operated during X startup, the device is identified and
operates correctly.

Expected results:

The device should initialize correctly even if it is not operated during X startup.

Additional info:
Comment 1 Matěj Cepl 2008-05-05 11:48:57 EDT
Could we get complete /var/log/Xorg.*.log attached to this bug, please?
Comment 2 Uwe Kubosch 2008-05-06 05:46:41 EDT
Created attachment 304615 [details]
X server log when the probe fails
Comment 3 Uwe Kubosch 2008-05-06 05:47:13 EDT
Created attachment 304616 [details]
X server log when the probe succeeds
Comment 4 Uwe Kubosch 2008-05-07 04:11:53 EDT
Did the logs help?
Comment 5 Peter Hutterer 2008-10-13 02:14:50 EDT
Uwe:
Is this still an issue? I could probably knock up a patch to fix that if you're willing to test it.
Comment 6 Uwe Kubosch 2008-10-13 18:52:45 EDT
Created attachment 320236 [details]
Naive patch to allow driver to start up without response to hardware probes.

Yes, this is still an issue.  We have downloaded the upstream sources and made a naive change to enable initialization of the driver.  I'll attach a patch for this.
Comment 7 Peter Hutterer 2008-10-13 20:02:19 EDT
Created attachment 320237 [details]
Add suppport for "Model" option, and support Sunit dSeries model

Here's two quick patches (in the same file) against git master.

Patch 1 adds general support for config option "Model" to the driver.
Patch 2 parses Option "Model" "Sunit dSeries" and does not execute the query commands if the model is set.

It's not exactly the same as your patch since it doesn't send anything to the device. From your previous logfile I can see that you're not getting any replies from the screen but I'm not sure if that also implies that you don't have to send the command.
Comment 8 Uwe Kubosch 2008-10-14 00:54:11 EDT
This looks great!  I'll test them as soon as can, by friday at the latest.

I'll report back here when I have tested the patches.
Comment 9 Peter Hutterer 2008-10-14 03:22:42 EDT
I'll just leave the needinfo flag here so we get notified for sure.
Comment 10 Jari Hakkarainen 2008-10-16 10:51:46 EDT
Hi Uwe, Peter and others

Great work guys! I have tested these patches with 7", 8" and 10" Sunit touchscreens under Ubuntu 8.04 without any problems (apart from calibration problems but that was expected). Maybe Uwe will test these patches under Fedora.

Now, Sunit d is actually dual display/touchscreen vehicle computer which means that it is possible to use two touchscreens with Sunit d. Both touchscreens use same COM2 port for sending data. First byte of the primary touchscreen (touchscreen connected to LVDS 1) is 55 (in hex) and first byte of secondary touchscreen (touchscreen connected to LVDS 2) is 66.

So, at some point there will be need for patch to support secondary touchscreen or own driver for Sunit d touchscreens. At the moment there are problems getting the secondary display work under linux but it will be fixed sooner or later.
Comment 11 Peter Hutterer 2008-10-20 02:15:33 EDT
Uwe: did you have any chance to test the patches for Fedora?

Unless you found any issues, they'll be going upstream.(In reply to comment #10)


> Now, Sunit d is actually dual display/touchscreen vehicle computer which means
> that it is possible to use two touchscreens with Sunit d. Both touchscreens use
> same COM2 port for sending data. First byte of the primary touchscreen
> (touchscreen connected to LVDS 1) is 55 (in hex) and first byte of secondary
> touchscreen (touchscreen connected to LVDS 2) is 66.

Jari, please take this upstream and file a bug on bugs.freedesktop.org. 
(it'll most likely be me doing it anyway if I find the time :)
Comment 12 Uwe Kubosch 2008-10-20 04:50:19 EDT
Sorry, I haven't found time to test this, and I probably will not find time any time soon, especially since the changes will go upstream if I do nothing :)

I have looked at the patches you sent, and they look good.


Uwe
Comment 13 Fedora Update System 2008-10-21 01:26:29 EDT
xorg-x11-drv-elographics-1.2.3-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xorg-x11-drv-elographics-1.2.3-1.fc9
Comment 14 Fedora Update System 2008-10-23 12:36:39 EDT
xorg-x11-drv-elographics-1.2.3-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-elographics'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9047
Comment 15 Fedora Update System 2008-11-06 21:50:43 EST
xorg-x11-drv-elographics-1.2.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.