Bug 445197 - Link from the report table does not show only the selected version
Link from the report table does not show only the selected version
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Reporting/Charting (Show other bugs)
3.2
All Linux
low Severity high (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-05 08:16 EDT by Jan Pazdziora
Modified: 2013-06-23 22:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 02:44:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2008-05-05 08:16:31 EDT
Description of problem:

I have a report

http://tinyurl.com/3ed2vh

which specifies a number of versions to be selected and also specifies version
to be shown on the horizontal axis -- the URL after wrapping is

https://bugzilla.redhat.com/report.cgi?x_axis_field=version
        &y_axis_field=component
        &z_axis_field=
        &query_format=report-table
        &short_desc_type=allwordssubstr
        &short_desc=
        &product=Fedora
        &version=7
        &version=8
        &version=rawhide
        &query_format=report-table
        &bug_status=NEW
        &bug_status=ASSIGNED
        &bug_status=NEEDINFO
        &bug_status=MODIFIED
        &bug_status=ON_DEV
        &bug_status=ON_QA
        &bug_status=VERIFIED
        &bug_status=FAILS_QA
        &bug_status=RELEASE_PENDING
        &bug_status=POST
        &bug_status=PASSES_QA
        &long_desc_type=substring
        &long_desc=
        &bug_file_loc_type=allwordssubstr
        &bug_file_loc=
        &status_whiteboard_type=allwordssubstr
        &status_whiteboard=
        &fixed_in_type=allwordssubstr
        &fixed_in=
        &qa_whiteboard_type=allwordssubstr
        &qa_whiteboard=
        &devel_whiteboard_type=allwordssubstr
        &devel_whiteboard=
        &keywords_type=allwords
        &keywords=
        &cust_facing=
        &cust_facing_type=substring
        &emailassigned_to1=1
        &emailtype1=exact
        &email1=
        &emailassigned_to2=1
        &emailreporter2=1
        &emailqa_contact2=1
        &emailcc2=1
        &emailtype2=exact
        &email2=
        &bugidtype=include
        &bug_id=
        &votes=
        &changedin=
        &chfieldfrom=
        &chfieldto=Now
        &chfieldvalue=
        &format=table
        &action=wrap
        &field0-0-0=component
        &type0-0-0=regexp
        &value0-0-0=%5Eperl-%3F

When I hit one of the non-Total numbers in the table, all bugs for the given
components are shown, not just those from the single column. The reason seems to
be that the list of version values from the report gets uses as well as the
version value of that particular column:

https://bugzilla.redhat.com/buglist.cgi?action=wrap
        &bug_file_loc_type=allwordssubstr
        &bug_status=NEW
        &bug_status=ASSIGNED
        &bug_status=NEEDINFO
        &bug_status=MODIFIED
        &bug_status=ON_DEV
        &bug_status=ON_QA
        &bug_status=VERIFIED
        &bug_status=FAILS_QA
        &bug_status=RELEASE_PENDING
        &bug_status=POST
        &bug_status=PASSES_QA
        &bugidtype=include
        &chfieldto=Now
        &cust_facing_type=substring
        &devel_whiteboard_type=allwordssubstr
        &emailassigned_to1=1
        &emailassigned_to2=1
        &emailcc2=1
        &emailqa_contact2=1
        &emailreporter2=1
        &emailtype1=exact
        &emailtype2=exact
        &field0-0-0=component
        &fixed_in_type=allwordssubstr
        &keywords_type=allwords
        &long_desc_type=substring
        &product=Fedora
        &qa_whiteboard_type=allwordssubstr
        &query_format=report-table
        &query_format=report-table
        &short_desc_type=allwordssubstr
        &status_whiteboard_type=allwordssubstr
        &type0-0-0=regexp
        &value0-0-0=%5Eperl-?
        &version=7
        &version=8
        &version=rawhide
        &=
        &component=perl
        &version=8

-- note the version=7, version=8, version=rawhide, and then the version=8 again.

Version-Release number of selected component (if applicable):

2.18-rh as of today.

How reproducible:

Deterministic.

Steps to Reproduce:
1. Use the tinyurl URL above.
2. Click on one of the values in the table. Chose the column where there are
other numbers in other columns, to see the effect.
  
Actual results:

List of bugs from all columns from that row.

Expected results:

List of only those bugs from the one row and column.

Additional info:
Comment 1 David Lawrence 2008-09-16 12:56:12 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 2 Jan Pazdziora 2008-09-17 02:44:32 EDT
This seems to have been fixed.

Closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.