Bug 445228 - Server crashes during install if usb keyboard/mouse removed
Server crashes during install if usb keyboard/mouse removed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-05-05 12:01 EDT by Jesse Keating
Modified: 2013-01-09 22:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 14:33:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X log file from machine (37.02 KB, text/plain)
2008-05-05 12:09 EDT, Jesse Keating
no flags Details

  None (edit)
Description Jesse Keating 2008-05-05 12:01:14 EDT
When I'm using a kvm to do install testing and I switch the KVM away to another
machine during the package installation, X will crash and cause the installer to
crash.

Trying again with nokill so that I can capture the traceback.
Comment 1 Jesse Keating 2008-05-05 12:09:42 EDT
Created attachment 304534 [details]
X log file from machine

Attached is the log file.  Looks like evdev again.  This is a Apple keyboard
with a mouse plugged into it, plugged into the kvm.
Comment 2 Bill Nottingham 2008-05-05 13:56:42 EDT
So, in my case, I get:

device_removed(ctx=whatever,
udi="/org/freedesktop/Hal/devices/usb_device_ffffffff_ffffffff_noserial_logicaldev_input)

which eventually crashes. For some reason, the debuginfo for hal.c isn't showing
up right, so it's a little hard to see where.
Comment 3 Bill Nottingham 2008-05-05 16:13:50 EDT
Should be fixed in xorg-x11-server-1.4.99.901-28.20080415.fc9
Comment 4 Jesse Keating 2008-05-06 14:33:13 EDT
Confirmed fixed.

Note You need to log in before you can comment on or make changes to this bug.