Bug 445284 - "Verify and boot" not working
"Verify and boot" not working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All Linux
high Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-05-05 17:53 EDT by Sebastian Vahl
Modified: 2008-05-09 13:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-09 13:09:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2008-05-05 17:53:21 EDT
Description of problem:
I've tried several of my local spins today to see if verifying the
image during boot is working. It seems to be not to work. Also the
latest official release, Fedora 9 Preview, has the same problem.

Version-Release number of selected component (if applicable):
latest git

How reproducible:
ever

Steps to Reproduce:
1. Boot Fedora-9-Preview
2. Select "Verify and boot"

  
Actual results:
nothing happens

Expected results:
media should be verified

Additional info:
The live image itself boots fine. The only problem is that it doesn't verify itself.
Comment 1 Jeremy Katz 2008-05-05 22:25:46 EDT
Ugh.  This is because isomd5sum is getting installed after the kernel and thus
the initrd isn't ending up with checkisomd5sum

Could make mkinitrd depend on isomd5sum, but that's a little bit ugly.  But
given where we are time-wise, it's probably the only viable solution.  The real
fix is that we need support within rpm to hint that things should be installed first
Comment 2 Jeremy Katz 2008-05-05 23:09:50 EDT
Or actually, it looks like I can get away with adding some whiteout in
livecd-creator...  starting a full set of images to make sure I'm not missing
something.
Comment 3 Jeremy Katz 2008-05-06 10:09:26 EDT
Yeah, I lied.  I just got lucky with the image I built and it was already ending
up with the right ordering.

Just going to build mkinitrd with the requires.
Comment 4 Bill Nottingham 2008-05-09 13:09:04 EDT
This worked in a test of a F9 livecd a couple of days ago.

Note You need to log in before you can comment on or make changes to this bug.