Bug 445289 - Pyrex is out of date (current is 0.9.6.4), missing emacs mode
Pyrex is out of date (current is 0.9.6.4), missing emacs mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Pyrex (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
http://www.cosc.canterbury.ac.nz/greg...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-05 18:59 EDT by Kyle VanderBeek
Modified: 2008-06-02 00:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 11:46:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updated .spec file with new version and emacs-pyrex subpackage (6.82 KB, text/plain)
2008-05-05 18:59 EDT, Kyle VanderBeek
no flags Details
Updated .spec with site-start for emacs package (7.07 KB, text/plain)
2008-05-05 20:03 EDT, Kyle VanderBeek
no flags Details
emacs site init for pyrex-mode (178 bytes, text/plain)
2008-05-05 20:04 EDT, Kyle VanderBeek
no flags Details

  None (edit)
Description Kyle VanderBeek 2008-05-05 18:59:54 EDT
Description of problem:
Pyrex has had several updates and bugfixes since the last Fedora packaged
version.  Additionally, the emacs mode included in the distribution isn't being
 packaged.

Version-Release number of selected component (if applicable):
0.9.5.1a

How reproducible:
Always.

Steps to Reproduce:
1. Look at version of Pyrex.
2. Realize that it is old.

I'm including an updated spec file.
Comment 1 Kyle VanderBeek 2008-05-05 18:59:54 EDT
Created attachment 304575 [details]
updated .spec file with new version and emacs-pyrex subpackage
Comment 2 Kyle VanderBeek 2008-05-05 19:42:09 EDT
Don't bother with this yet.  I need to write an auto-load hook file for emacs.
Comment 3 Kyle VanderBeek 2008-05-05 20:03:30 EDT
Created attachment 304578 [details]
Updated .spec with site-start for emacs package
Comment 4 Kyle VanderBeek 2008-05-05 20:04:11 EDT
Created attachment 304579 [details]
emacs site init for pyrex-mode
Comment 5 Matthew Barnes 2008-05-05 20:46:06 EDT
I'm having a different problem with this.  The emacs package names its binary
emacs-22.2, so this command fails:

  "emacs -batch -f batch-byte-compile Tools/*.el"

Not sure how best to address that.  I'd really hate to have to rebuild this
package for every minor version increment of emacs.
Comment 6 Kyle VanderBeek 2008-05-05 22:36:43 EDT
Sounds like you might be getting bit by an "alternatives" bug:
https://bugzilla.redhat.com/show_bug.cgi?id=394131

Properly installed, there will be a plain emacs command.
Comment 7 Kyle VanderBeek 2008-05-06 15:30:29 EDT
I noticed in the build log at
http://koji.fedoraproject.org/packages/Pyrex/0.9.6.4/1.fc10/data/logs/noarch/build.log
that it had trouble figuring out the macros based on the pkg-config command
which wasn't present.  Eventually, this will break things when it can't figure
out the emcas directories.

Should we add a "BuildRequires: pkgconfig"?

Comment 8 Matthew Barnes 2008-05-06 16:11:28 EDT
Done.  How does this look?
http://koji.fedoraproject.org/packages/Pyrex/0.9.6.4/2.fc10/data/logs/noarch/build.log
Comment 9 Kyle VanderBeek 2008-05-06 17:01:00 EDT
Looks good to me!
Comment 10 Matthew Barnes 2008-05-07 11:46:10 EDT
Packages built for Fedora 8 and 9.  The F9 one will have to wait a week and go
out as a post-release update.

Thanks a lot for your help with this, Kyle.  It would have taken me ages to
figure out the emacs stuff.
Comment 11 Fedora Update System 2008-05-07 12:07:35 EDT
Pyrex-0.9.6.4-1.fc8 has been submitted as an update for Fedora 8
Comment 12 Fedora Update System 2008-05-07 12:08:55 EDT
Pyrex-0.9.6.4-1.fc9 has been submitted as an update for Fedora 9
Comment 13 Fedora Update System 2008-05-21 06:59:42 EDT
Pyrex-0.9.6.4-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2008-05-21 07:08:13 EDT
Pyrex-0.9.6.4-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Kyle VanderBeek 2008-06-02 00:04:37 EDT
*** Bug 226339 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.