Bug 445307 - Memory corruption with cvs history
Memory corruption with cvs history
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cvs (Show other bugs)
8
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-05 23:42 EDT by Jerry James
Modified: 2015-02-01 17:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 08:20:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2008-05-05 23:42:29 EDT
Description of problem:
I ran "cvs history" on a file to see when it was created.  I then saw:
*** glibc detected *** cvs: malloc(): memory corruption: 0x0a079620 ***
======= Backtrace: =========
/lib/libc.so.6[0x438253]
/lib/libc.so.6(__libc_malloc+0x7b)[0x439b7b]
/lib/libc.so.6(getservbyname+0x11d)[0x4ba99d]
cvs[0x80561db]
cvs[0x8057440]
cvs[0x805af9d]
cvs[0x806ad20]
cvs[0x80774b3]
/lib/libc.so.6(__libc_start_main+0xe0)[0x3e4390]
cvs[0x804b001]
======= Memory map: ========
00101000-0010c000 r-xp 00000000 fd:00 9864778    /lib/libgcc_s-4.1.2-20070925.so.1
0010c000-0010d000 rwxp 0000a000 fd:00 9864778    /lib/libgcc_s-4.1.2-20070925.so.1
00110000-00111000 r-xp 00110000 00:00 0          [vdso]
0011a000-00131000 r-xp 00000000 fd:00 9864087    /lib/libaudit.so.0.0.0
00131000-00133000 rwxp 00016000 fd:00 9864087    /lib/libaudit.so.0.0.0
00135000-0013f000 r-xp 00000000 fd:00 9864101    /lib/libpam.so.0.81.8
0013f000-00140000 rwxp 0000a000 fd:00 9864101    /lib/libpam.so.0.81.8
00307000-00309000 r-xp 00000000 fd:00 9863238    /lib/libcom_err.so.2.1
00309000-0030a000 rwxp 00001000 fd:00 9863238    /lib/libcom_err.so.2.1
003af000-003ca000 r-xp 00000000 fd:00 9864753    /lib/ld-2.7.so
003ca000-003cb000 r-xp 0001a000 fd:00 9864753    /lib/ld-2.7.so
003cb000-003cc000 rwxp 0001b000 fd:00 9864753    /lib/ld-2.7.so
003ce000-00521000 r-xp 00000000 fd:00 9864754    /lib/libc-2.7.so
00521000-00523000 r-xp 00153000 fd:00 9864754    /lib/libc-2.7.so
00523000-00524000 rwxp 00155000 fd:00 9864754    /lib/libc-2.7.so
00524000-00527000 rwxp 00524000 00:00 0 
00529000-0052c000 r-xp 00000000 fd:00 34173827   /usr/lib/libdes425.so.3.0
0052c000-0052d000 rwxp 00002000 fd:00 34173827   /usr/lib/libdes425.so.3.0
0052f000-00546000 r-xp 00000000 fd:00 34147470   /usr/lib/libkrb4.so.2.0
00546000-00547000 rwxp 00017000 fd:00 34147470   /usr/lib/libkrb4.so.2.0
00547000-0054c000 rwxp 00547000 00:00 0 
00554000-00557000 r-xp 00000000 fd:00 9864755    /lib/libdl-2.7.so
00557000-00558000 r-xp 00002000 fd:00 9864755    /lib/libdl-2.7.so
00558000-00559000 rwxp 00003000 fd:00 9864755    /lib/libdl-2.7.so
00576000-00588000 r-xp 00000000 fd:00 9864757    /lib/libz.so.1.2.3
00588000-00589000 rwxp 00011000 fd:00 9864757    /lib/libz.so.1.2.3
00b0f000-00b28000 r-xp 00000000 fd:00 9864788    /lib/libselinux.so.1
00b28000-00b2a000 rwxp 00018000 fd:00 9864788    /lib/libselinux.so.1
00b2c000-00b41000 r-xp 00000000 fd:00 9864767    /lib/libnsl-2.7.so
00b41000-00b42000 r-xp 00014000 fd:00 9864767    /lib/libnsl-2.7.so
00b42000-00b43000 rwxp 00015000 fd:00 9864767    /lib/libnsl-2.7.so
00b43000-00b45000 rwxp 00b43000 00:00 0 
00b8d000-00b9d000 r-xp 00000000 fd:00 9864769    /lib/libresolv-2.7.so
00b9d000-00b9e000 r-xp 00010000 fd:00 9864769    /lib/libresolv-2.7.so
00b9e000-00b9f000 rwxp 00011000 fd:00 9864769    /lib/libresolv-2.7.so
00b9f000-00ba1000 rwxp 00b9f000 00:00 0 
00ba3000-00bd0000 r-xp 00000000 fd:00 34173760   /usr/lib/libgssapi_krb5.so.2.2
00bd0000-00bd1000 rwxp 0002d000 fd:00 34173760   /usr/lib/libgssapi_krb5.so.2.2
00bd3000-00bdb000 r-xp 00000000 fd:00 34154252   /usr/lib/libkrb5support.so.0.1
00bdb000-00bdc000 rwxp 00007000 fd:00 34154252   /usr/lib/libkrb5support.so.0.1
00bde000-00c03000 r-xp 00000000 fd:00 32243726   /usr/lib/libk5crypto.so.3.1
00c03000-00c04000 rwxp 00025000 fd:00 32243726   /usr/lib/libk5crypto.so.3.1
00d9a000-00d9c000 r-xp 00000000 fd:00 9864768    /lib/libkeyutils-1.2.so
00d9c000-00d9d000 rwxp 00001000 fd:00 9864768    /lib/libkeyutils-1.2.so
046be000-0474e000 r-xp 00000000 fd:00 34152554   /usr/lib/libkrb5.so.3.3
0474e000-04751000 rwxp 0008f000 fd:00 34152554   /usr/lib/libkrb5.so.3.3
0514f000-05158000 r-xp 00000000 fd:00 9864777    /lib/libcrypt-2.7.so
05158000-05159000 r-xp 00008000 fd:00 9864777    /lib/libcrypt-2.7.so
05159000-0515a000 rwxp 00009000 fd:00 9864777    /lib/libcrypt-2.7.so
0515a000-05181000 rwxp 0515a000 00:00 0 
08047000-080dc000 r-xp 00000000 fd:00 34160410   /usr/bin/cvs
080dc000-080de000 rw-p 00094000 fd:00 34160410   /usr/bin/cvs
080de000-080df000 rw-p 080de000 00:00 0 
0a079000-0a09a000 rw-p 0a079000 00:00 0 
b7d00000-b7d21000 rw-p b7d00000 00:00 0 
b7d21000-b7e00000 ---p b7d21000 00:00 0 
b7ee7000-b7eec000 rw-p b7ee7000 00:00 0 
bfba0000-bfbb5000 rw-p bffea000 00:00 0          [stack]

Running under gdb gives this backtrace:
#0  0x00110402 in __kernel_vsyscall ()
#1  0x003f7690 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#2  0x003f8f91 in abort () at abort.c:88
#3  0x0042f9eb in __libc_message (do_abort=2, 
    fmt=0x4f8864 "*** glibc detected *** %s: %s: 0x%s ***\n")
    at ../sysdeps/unix/sysv/linux/libc_fatal.c:170
#4  0x00438253 in _int_malloc (av=0x524120, bytes=1024) at malloc.c:5891
#5  0x00439b7b in __libc_malloc (bytes=1024) at malloc.c:3553
#6  0x004ba99d in getservbyname (name=0x80bbea1 "cvspserver", 
    proto=0x80bbe9d "tcp") at ../nss/getXXbyYY.c:103
#7  0x080561db in get_port_number (envname=0x80bbeac "CVS_CLIENT_PORT", 
    portname=0x80bbea1 "cvspserver", defaultport=2401) at client.c:3603
#8  0x08057440 in connect_to_pserver (root=0x99f5520, to_server_p=0x80dda84, 
    from_server_p=0x80dda88, verify_only=0, do_gssapi=0) at client.c:3753
#9  0x0805af9d in start_server () at client.c:4442
#10 0x0806ad20 in history (argc=1, argv=0x99f8eec) at history.c:562
#11 0x080774b3 in main (argc=135001871, argv=Cannot access memory at address 0xa
) at main.c:990
#12 0x003e4390 in __libc_start_main (main=0x8077000 <main>, argc=3, 
    ubp_av=0xbf968554, init=0x80b8ad0 <__libc_csu_init>, 
    fini=0x80b8ac0 <__libc_csu_fini>, rtld_fini=0x3bd940 <_dl_fini>, 
    stack_end=0xbf96854c) at libc-start.c:220
#13 0x0804b001 in _start ()

Version-Release number of selected component (if applicable):
cvs-1.11.22-12.fc8

How reproducible:
Always

Steps to Reproduce:
1. Get a copy of the XEmacs 21.5 CVS repository
2. cvs history configure.ac

Actual results:
I get the memory corruption error above and cvs then hangs.

Expected results:
The history of the indicated file should be printed.

Additional info:
Comment 1 Jiri Moskovcak 2008-05-15 10:04:59 EDT
I recently updated my system and it seems that bug has been fixed (at least I'm 
not able to reproduce anymore). Can you please try it.

Thanks,
Jirka
Comment 2 Jerry James 2008-10-22 10:08:51 EDT
Sorry to leave this sitting for so long.  With cvs-1.11.22-14.fc9, I am no longer able to reproduce the problem either.  Go ahead and mark this bug as fixed.  Thank you!
Comment 3 Jiri Moskovcak 2008-10-24 08:20:39 EDT
According to coments above it seems that this problem has been fixed.

Note You need to log in before you can comment on or make changes to this bug.