Bug 445309 - Totem no longer plays DVDs
Totem no longer plays DVDs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-05 23:56 EDT by Rodd Clarkson
Modified: 2008-05-19 07:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 07:23:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Message when a DVD is inserted in the drive (12.10 KB, image/png)
2008-05-06 06:41 EDT, Rodd Clarkson
no flags Details
Message when I try to play DVD from File menu (16.65 KB, image/png)
2008-05-06 06:41 EDT, Rodd Clarkson
no flags Details
About Totem (using gstreamer) (25.17 KB, image/png)
2008-05-19 07:14 EDT, Rodd Clarkson
no flags Details

  None (edit)
Description Rodd Clarkson 2008-05-05 23:56:46 EDT
Description of problem:

Shortly after install f9-preview and installing the necessary livna
gst-plugins-* totem played DVDs.  I couldn't get the DVD menu to work, but it
played the movie and navigation worked well (which was a big improvement).

Since this time an update in rawhide (or possibly livna, but I don't think so)
has resulted in DVD playback no longer working.  I know get a message saying
that I don't have the necessary plugins.

I've also tried the old dvd:///[0-9] method of playback, but this doesn't work
either.



Version-Release number of selected component (if applicable):

[rodd@localhost yum.repos.d]$ rpm -q totem
totem-2.23.2-2.fc9.i386

[rodd@localhost yum.repos.d]$ rpm -qa | grep gst
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.i386
gstreamer-plugins-ugly-0.10.7-1.lvn9.i386
gstreamer-plugins-bad-0.10.7-1.lvn9.i386
gstreamer-0.10.19-1.fc9.i386
gstreamer-plugins-good-0.10.7-1.fc9.i386
gstreamer-plugins-schroedinger-1.0.0-1.fc9.i386
gstreamer-tools-0.10.19-1.fc9.i386
gstreamer-plugins-base-0.10.19-1.fc9.i386
gstreamer-ffmpeg-0.10.3-4.lvn9.i386
gstreamer-python-0.10.11-2.fc9.i386
gstreamer-plugins-farsight-0.12.6-1.fc9.i386
gstreamer-plugins-bad-extras-0.10.7-1.lvn9.i386
totem-gstreamer-2.23.2-2.fc9.i386
Comment 1 Bastien Nocera 2008-05-06 04:55:09 EDT
You're probably missing a decent mpeg demuxer:
http://bugzilla.livna.org/show_bug.cgi?id=1523

What the actual error message you're getting?
Comment 2 Rodd Clarkson 2008-05-06 06:41:01 EDT
Created attachment 304620 [details]
Message when a DVD is inserted in the drive

This is what I see when I put a DVD in the drive and then tell it to play the
DVD.
Comment 3 Rodd Clarkson 2008-05-06 06:41:57 EDT
Created attachment 304621 [details]
Message when I try to play DVD from File menu

This is what I get when I try to play the inserted DVD from the File menu
Comment 4 Stewart Adam 2008-05-06 08:26:52 EDT
Is the disc encrypted? DVD playback works for me with the gstreamer and xine
backends.
Comment 5 Rodd Clarkson 2008-05-06 08:41:01 EDT
Most likely.  But when I first installed f9-preview (and related livna packages)
it played fine.  So something has gone wrong between then and now.
Comment 6 Bug Zapper 2008-05-14 06:42:03 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bastien Nocera 2008-05-19 05:30:06 EDT
Note: are you sure you are using the GStreamer backend of Totem. Check the about
box please, and run "totem-backend -b gstreamer" as root if GStreamer isn't
being used.
Comment 8 Rodd Clarkson 2008-05-19 07:14:53 EDT
Created attachment 305925 [details]
About Totem (using gstreamer)

This is the about dialog.  I'm pretty sure this means I'm using gstreamer.
Comment 9 Rodd Clarkson 2008-05-19 07:18:45 EDT
Argh, I've just read back over the comments and you are right.  I wasn't using
gstreamer (xine had been installed at some stage, but I didn't do it).

I thought I posted this (so I'm wondering where I posted it) but I did comment
somewhere that I removed xine and switched back to gstreamer and could play
DVD's again, but that the seek stuff wasn't working.

Argh. I'm going to track down where I stuffed up and clear the water and close
some bugs.
Comment 10 Rodd Clarkson 2008-05-19 07:23:07 EDT
I'm going to close this.

The problem with seeking seems to be reported in #445491 and I don't know where
that other comment about using xine went.

Note You need to log in before you can comment on or make changes to this bug.