Bug 445314 - perl-Net-DNS: resolver->bgsend() gives unexpected warning
perl-Net-DNS: resolver->bgsend() gives unexpected warning
Status: CLOSED DUPLICATE of bug 437681
Product: Fedora
Classification: Fedora
Component: perl-Net-DNS (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-05-06 01:19 EDT by Dick Franks
Modified: 2008-05-12 06:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-12 06:02:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dick Franks 2008-05-06 01:19:29 EDT
Description of problem:

Use of resolver bgsend() method in (Fedora 9-pre) perl-Net-DNS RPM with IPv6
enabled provokes unexpected runtime warning.

This behaviour does not occur when using the published Net::DNS CPAN library

Observed warning is a direct consequence of an ill-considered and unnecessary
modification of the resolver Base.pm source.

Required prominent notice and date of modification are both absent, contrary to
section 2(a) of GPL Version 2, and condition 3 of the Perl Artistic License.

Remedy: Ensure that perl-Net-DNS is a verbatim redistribution of the
corresponding CPAN library component.

Version-Release number of selected component (if applicable): 0.63-3.fc9.i386

How reproducible: 100%

Steps to Reproduce:

Execute code fragment on machine with IPv6 support

	#!/usr/bin/perl -w
	#	perl-Net-DNS.i386: resolver->bgsend() gives unexpected warning
	use Net::DNS;
	my $resolver=Net::DNS::Resolver->new;
	my $q=$resolver->bgsend('www.example.com','A');

Actual results:

Runtime warning occurs at line 8.

Argument "AI_NUMERICHOST" isn't numeric in subroutine entry at
line 945.

Expected results:

Additional info: 

*** /home/rwf/cpan/build/Net-DNS-0.63-T1FEq9/lib/Net/DNS/Resolver/Base.pm
2008-02-08 15:25:52.000000000 +0000
2008-04-09 16:07:49.000000000 +0100
*** 62,68 ****
  	 # INET6 prior to 2.01 will not work; sorry.
  	 eval {require IO::Socket::INET6; IO::Socket::INET6->VERSION("2.00");}
  	 ) {
!  	import Socket6;
--- 62,68 ----
  	 # INET6 prior to 2.01 will not work; sorry.
  	 eval {require IO::Socket::INET6; IO::Socket::INET6->VERSION("2.00");}
  	 ) {
!  	Socket6->import(qw(getaddrinfo));
Comment 1 Marcela Mašláňová 2008-05-09 02:56:56 EDT
This change was done for 437681 :-/

I reopened related bug and change Net::DNS back to previous state, because this
patch maybe fix the previous problem but bring new one.
Comment 2 Dick Franks 2008-05-09 12:13:09 EDT

Please note that Net::DNS is licensed material, and you MUST NOT make changes
without adding a notice to that effect, date and bug reference.

Bugs, when you find one, should be logged via CPAN RT. Anything major will
receive prompt attention.

Comment 3 Marcela Mašláňová 2008-05-12 06:02:32 EDT
The previous patch was removed and this issues was solved in #437681

*** This bug has been marked as a duplicate of 437681 ***

Note You need to log in before you can comment on or make changes to this bug.